Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#56143 - [linux] Kernel 4.13.8-1 Unexpected IRQ trap making system unusable after boot

Attached to Project: Arch Linux
Opened by Max Wang (maxwyb) - Saturday, 28 October 2017, 06:34 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 31 October 2017, 12:53 GMT
Task Type Bug Report
Category Kernel
Status Assigned
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


I upgraded from linux-4.12.8-2-x86_64 and linux-firmware-20170622.7d2c913-1-any to linux-4.13.8-1 and linux-firmware-20171009.bf04291-1-any, on my Samsung Chromebook 3 (XE500C13-K02US). It has Intel Celeron N3050 (Braswell architecture) and RW_LEGACY firmware. System boots normally, gets stuck at the login screen and prompt "unexpected IRQ trap at vector 76" every few seconds. It does not respond to any keyboard input so the I can only do a hard restart; system is unusable.

This is a bare minimum Arch Linux base system, with almost no additional packages installed and no window system. I tried adding "acpi=off" and/or "noapic" in grub boot settings which make system stuck at boot. Blacklisting `uvcvideo` module doesn't work as well (I don't have explicit evidence that the problem is related to `uvcvideo`; just a guess)

Downgrading into old linux kernel and linux-firmware solved the problem.

Additional info:
* package version(s)
linux-4.13.8-1 and linux-firmware-20171009.bf04291-1-any

* config and/or log files etc.
Related `journalctl` logs are attached below.

Steps to reproduce:
`pacman -Syu` on a Samsung Chromebook 3.
This task depends upon

Comment by Doug Newgard (Scimmia) - Saturday, 28 October 2017, 12:52 GMT
What does "stuck at the login screen" mean? Your DM is locking up?
Comment by Eli Schwartz (eschwartz) - Sunday, 29 October 2017, 03:29 GMT
"almost no additional packages installed and no window system" so I assume this means the tty login.
Comment by Max Wang (maxwyb) - Sunday, 29 October 2017, 06:56 GMT
Yes it's the tty login; I haven't took a picture of the login screen, but this is basically how it looks like:
Arch Linux 4.13.8-1-ARCH (tty1)
max-arch login: [(timestamp)] Unexpected IRQ trap at vector 76
[(another timestamp)] Unexpected IRQ trap at vector 76
[(another timestamp)] Unexpected IRQ trap at vector 76
[(another timestamp)] Unexpected IRQ trap at vector 76
Several of these messages would pop up every 3 seconds or so, eventually filling up the screen. System is not responding to keyboard interrupt, so I cannot type anything here (to login).

Sorry I am a beginner on Linux and haven't looked into dm-cache yet (if this is what you are referring to), but I would greatly appreciate if you want to provide some guidance on how I can investigate on it. Also FYI, the machine has a 16GB eMMC soldered on its motherboard and /home is mounted from a 32GB MicroSD card. Attached a screenshot to show my disk layout.
Comment by Nicolas Belouin (diconico07) - Friday, 29 December 2017, 12:22 GMT
Same issue with an ASUS chromebook (Terra).

Setting those config knob to Y solved the problem :

I guess it might partly be caused by solved kernel bug #194945 ( I haven't looked into all details, but the fix introduced by commit 845e405e5e6c9dc9ed10306a4b5bfeaefebc2e84 looks like its code path must be loaded first, meaning those knobs have to be set to Y.
Comment by loqs (loqs) - Friday, 29 December 2017, 20:11 GMT Comment by Nicolas Belouin (diconico07) - Friday, 29 December 2017, 21:31 GMT
Just checked with 4.14.10 from testing (with the two config knobs to M): no more IRQ trap storm, but still no keyboard.