Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56141 - [valgrind] addr16 prefix patch

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Friday, 27 October 2017, 18:38 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 14 November 2017, 02:44 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

A trivial C program fails instrumentation due to
superflous addr16 prefix in first call to a C
library function.

This bug is known and has been fixed in:

https://bugs.kde.org/show_bug.cgi?id=384230

In Archlinux32 there is a patch, see also:

https://bbs.archlinux32.org/viewtopic.php?pid=501

The question would be: does it make sense to take this bug into
a fix in the i686 valgrind package upstreams?

Additional info:
* package version(s): 3.13.0-3
* config and/or log files etc.


Steps to reproduce:

Simple program fails with:

cat >test.c <<EOF
#include <stdio.h>

int main( void )
{
puts( "hello" );
return 0;
}
EOF

gcc -g -o test test.c

valgrind ./test
vex x86->IR: unhandled instruction bytes: 0x67 0xE8 0xD3 0x8B
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 14 November 2017, 02:44 GMT
Reason for closing:  Won't fix
Additional comments about closing:  i686 is no longer supported, and therefore it makes no sense to add this patch. The upstream bugreport will suffice.
Comment by Andreas Baumann (andreas_baumann) - Friday, 27 October 2017, 18:38 GMT
This happens on 32-bit only, the package runs fine on 64-bit!

Loading...