Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56094 - [linux] xhci_hcd 0000:00:14.0: WARN Event TRB for slot 2 ep 8 with no TDs queued?

Attached to Project: Arch Linux
Opened by Juan Simón (j1simon) - Monday, 23 October 2017, 11:24 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 10 November 2017, 21:15 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since I upgraded to kernel 4.13.8-1-ARCH the message "xhci_hcd 0000:00:14.0: WARN Event TRB for slot 2 ep 8 with no TDs queued?" is repeated continuously.

"lsusb -v": https://www.dropbox.com/s/up7x8mjqmfcemjc/lsusb.out?dl=0
"journalctl -b": https://www.dropbox.com/s/9mp0g7ybg2muej2/journal.out?dl=0

This causes the mouse doesn't work well. The screen never turns off (energy saving) because the mouse seems to be always active. And if I watch a video on YouTube, Netflix,... the controls are never hidden for the same reason.

Kernels 4.12.x worked well.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 10 November 2017, 21:15 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#55803 
Comment by Juan Simón (j1simon) - Monday, 23 October 2017, 11:35 GMT
I have tested with a "normal" wired mouse and the bug is still present. Looks like it has nothing to do with the kind of mouse connected.
Comment by mattia (nTia89) - Tuesday, 24 October 2017, 16:41 GMT
I can't reproduce it.
Likely an hardware-related (USB hub) issue
Comment by Juan Simón (j1simon) - Wednesday, 25 October 2017, 06:35 GMT
Output of "lspci -v":

00:00.0 Host bridge: Intel Corporation Intel Kaby Lake Host Bridge (rev 05)
Subsystem: Elitegroup Computer Systems Intel Kaby Lake Host Bridge
Flags: bus master, fast devsel, latency 0
Capabilities: <access denied>

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04) (prog-if 00 [VGA controller])
Subsystem: Elitegroup Computer Systems HD Graphics 630
Flags: bus master, fast devsel, latency 0, IRQ 315
Memory at de000000 (64-bit, non-prefetchable) [size=16M]
Memory at c0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
Subsystem: Elitegroup Computer Systems Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
Flags: fast devsel, IRQ 255
Memory at df132000 (64-bit, non-prefetchable) [disabled] [size=4K]
Capabilities: <access denied>

00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31) (prog-if 30 [XHCI])
Subsystem: Elitegroup Computer Systems Sunrise Point-H USB 3.0 xHCI Controller
Flags: bus master, medium devsel, latency 0, IRQ 316
Memory at df110000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: xhci_hcd
Kernel modules: xhci_pci

00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
Subsystem: Elitegroup Computer Systems Sunrise Point-H Thermal subsystem
Flags: fast devsel, IRQ 18
Memory at df131000 (64-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>
Kernel driver in use: intel_pch_thermal
Kernel modules: intel_pch_thermal

00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #0 (rev 31)
Subsystem: Elitegroup Computer Systems Sunrise Point-H Serial IO I2C Controller
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at df130000 (64-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>
Kernel driver in use: intel-lpss
Kernel modules: intel_lpss_pci

00:15.1 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #1 (rev 31)
Subsystem: Elitegroup Computer Systems Sunrise Point-H Serial IO I2C Controller
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at df12f000 (64-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>
Kernel driver in use: intel-lpss
Kernel modules: intel_lpss_pci

00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
Subsystem: Elitegroup Computer Systems Sunrise Point-H CSME HECI
Flags: bus master, fast devsel, latency 0, IRQ 318
Memory at df12e000 (64-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>
Kernel driver in use: mei_me
Kernel modules: mei_me

00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31) (prog-if 01 [AHCI 1.0])
Subsystem: Elitegroup Computer Systems Sunrise Point-H SATA controller [AHCI mode]
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 317
Memory at df128000 (32-bit, non-prefetchable) [size=8K]
Memory at df12d000 (32-bit, non-prefetchable) [size=256]
I/O ports at f090 [size=8]
I/O ports at f080 [size=4]
I/O ports at f060 [size=32]
Memory at df12c000 (32-bit, non-prefetchable) [size=2K]
Capabilities: <access denied>
Kernel driver in use: ahci
Kernel modules: ahci

00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0, IRQ 314
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: 0000e000-0000efff [size=4K]
Memory behind bridge: df000000-df0fffff [size=1M]
Prefetchable memory behind bridge: None
Capabilities: <access denied>
Kernel driver in use: pcieport
Kernel modules: shpchp

00:1e.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO UART #0 (rev 31)
Subsystem: Elitegroup Computer Systems Sunrise Point-H Serial IO UART
Flags: bus master, fast devsel, latency 0, IRQ 20
Memory at df12b000 (64-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>
Kernel driver in use: intel-lpss
Kernel modules: intel_lpss_pci

00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
Subsystem: Elitegroup Computer Systems Sunrise Point-H LPC Controller
Flags: bus master, medium devsel, latency 0

00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
Subsystem: Elitegroup Computer Systems Sunrise Point-H PMC
Flags: fast devsel
Memory at df124000 (32-bit, non-prefetchable) [disabled] [size=16K]

00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
Subsystem: Elitegroup Computer Systems Sunrise Point-H HD Audio
Flags: bus master, fast devsel, latency 32, IRQ 320
Memory at df120000 (64-bit, non-prefetchable) [size=16K]
Memory at df100000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
Subsystem: Elitegroup Computer Systems Sunrise Point-H SMBus
Flags: medium devsel, IRQ 16
Memory at df12a000 (64-bit, non-prefetchable) [size=256]
I/O ports at f040 [size=32]
Kernel driver in use: i801_smbus
Kernel modules: i2c_i801

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
Subsystem: Elitegroup Computer Systems RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
Flags: bus master, fast devsel, latency 0, IRQ 319
I/O ports at e000 [size=256]
Memory at df004000 (64-bit, non-prefetchable) [size=4K]
Memory at df000000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: r8169
Kernel modules: r8169

Comment by Juan Simón (j1simon) - Wednesday, 01 November 2017, 10:51 GMT
In linux-usb@vger.kernel.org has answer me with this patch but only solves the warning messages.
Comment by Juan Simón (j1simon) - Thursday, 09 November 2017, 12:19 GMT
The problem is in Arch Linux (and derivatives) exclusively. It fails too with Manjaro but no with OpenSuse Tumbleweed.
Comment by Juan Simón (j1simon) - Friday, 10 November 2017, 08:22 GMT
It's solved with a trick: https://bbs.archlinux.org/viewtopic.php?pid=1739030#p1739030
The problem is in upstream kernel.

Loading...