Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56089 - [ffmpeg] no video playback with epiphany or mpv

Attached to Project: Arch Linux
Opened by Stefan (steinwanderer) - Monday, 23 October 2017, 05:46 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 27 November 2017, 20:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Christian Hesse (eworm)
Maxime Gauduin (Alucryd)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After upgrading ffmpeg, video playback stopped working (mpv). Also no videos in epiphany.
Downgrading to ffmpeg-1:3.3.4 solves this and video playback is flawless.

Additional info:

* package version(s)

ffmpeg-1:3.4-2

* config and/or log files etc.

No errors showed, no entries in log/journal

Steps to reproduce:

Upgrade to ffmpeg-1:3.4-2 and try to play video.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 27 November 2017, 20:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  Since ffmpeg 1:3.4-4 all ffmpeg consumers should be able to play videos just fine, even if they do log deprecation warnings.
Comment by Levente Polyak (anthraxx) - Monday, 23 October 2017, 06:04 GMT Comment by Eli Schwartz (eschwartz) - Monday, 30 October 2017, 13:37 GMT
This looks to be https://trac.ffmpeg.org/ticket/6767 instead, fixed with http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=a606f27f4c610708fa96e35eed7b7537d3d8f712 which re-adds the old API with a deprecation warning.
Also fixed the deprecated API usage in mpv with https://github.com/mpv-player/mpv/commit/e9dc4ac86f9dbd59147963d08ec8447bba3ed0bb


EDIT: mildly confused as to how the OP was using ffmpeg 1:3.4-2 which is the libva 2 rebuild in [staging], but this affects 1:3.4-1 also so yeah.
Comment by Stefan (steinwanderer) - Thursday, 02 November 2017, 13:16 GMT
My ffmpeg 1:3.4-2 was a local rebuild of ffmpeg 1:3.4-1 only with crystalhd libs installed to enable support for crystalhd.
Sorry, my bad for not mention it.
Comment by Maxime Gauduin (Alucryd) - Thursday, 02 November 2017, 14:28 GMT
Backported the upstream fix into 1:3.4-4, things had changed since and I had to adapt the patch, hopefully it didn't break anything. Adding Christian so that he can have a look at backporting the mpv patch.
Comment by Christian Hesse (eworm) - Friday, 03 November 2017, 13:24 GMT
Should be fixed with mpv 1:0.27.0-4. Anybody wants to verify?
Comment by Łukasz Skocz (kaszak696) - Sunday, 26 November 2017, 09:41 GMT
The patch seems to cause MPV to spam this message:

[ffmpeg] Invalid return value 0 for stream protocol

in terminal when watching Twitch streams. It got filed in MPV's bugtracker here: https://github.com/mpv-player/mpv/issues/5118
Doesn't seem to do anything else though, and the playback works normally.
Comment by Eli Schwartz (eschwartz) - Sunday, 26 November 2017, 13:07 GMT
I'm a bit confused here, as the mpv patch is supposed to make it use the newer API, and the ffmpeg patch is supposed to make the older API log that warning instead of erroring out.
Comment by Łukasz Skocz (kaszak696) - Sunday, 26 November 2017, 19:20 GMT
MPV plays Twitch content through youtube-dl, maybe it's the culprit? Either way, it seems to cause no playback issues, so it's probably safe to let it resolve itself with new upstream releases of ffmpeg and MPV, in due time.

Loading...