Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56002 - [xf86-video-amdgpu] stuttering 2D rendering while 3D seems fine

Attached to Project: Arch Linux
Opened by Milan (verymilan) - Sunday, 15 October 2017, 19:53 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 02 April 2018, 17:19 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello there, first at all, i am not sure where to file this issue report so my current "workaround" is to use the archlinux issue tracker.
I recently got a new rx560 and installed amdgpu plus vdpau packages.
While 3D rendering seems to work as expected, all the 2D rendering is unclean.
It is no tearing but stuttering that is to see on scrolling/gnome&such effects/cameradrives in movies/cursors in gimp and so on.


Additional info:

~ Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon RX 560] (rev cf)

extra/xf86-video-amdgpu 1.4.0-1
extra/glu 9.0.0-4
extra/libtxc_dxtn 1.0.1-6
extra/libva-mesa-driver 17.2.2-1
extra/mesa 17.2.2-1
extra/mesa-demos 8.3.0-4
extra/mesa-vdpau 17.2.2-1
multilib/lib32-libtxc_dxtn 1.0.1-5
multilib/lib32-mesa 17.2.0-2

core/linux 4.13.5-1 (base)
core/linux-api-headers 4.12.7-1
core/linux-firmware 20170907.a61ac5c-1

extra/xorg-server 1.19.5-1 (xorg)

/sys/class/drm/card0/device/power_dpm_force_performance_level
currently 'auto', changing it had no effect on this issue.

~> dmesg|grep amdgpu
[ 3.909508] [drm] amdgpu kernel modesetting enabled.
[ 3.917766] fb: switching to amdgpudrmfb from EFI VGA
[ 3.947569] amdgpu 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff
[ 3.955471] amdgpu 0000:01:00.0: VRAM: 4096M 0x0000000000000000 - 0x00000000FFFFFFFF (4096M used)
[ 3.955475] amdgpu 0000:01:00.0: GTT: 4096M 0x0000000100000000 - 0x00000001FFFFFFFF
[ 3.955739] [drm] amdgpu: 4096M of VRAM memory ready
[ 3.955741] [drm] amdgpu: 4096M of GTT memory ready.
[ 3.957029] amdgpu 0000:01:00.0: amdgpu: using MSI.
[ 3.957053] [drm] amdgpu: irq initialized.
[ 4.135366] amdgpu: [powerplay] amdgpu: powerplay sw initialized
[ 4.146914] amdgpu 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000100000008, cpu addr 0xffff9772a5738008
[ 4.146982] amdgpu 0000:01:00.0: fence driver on ring 1 use gpu addr 0x0000000100000018, cpu addr 0xffff9772a5738018
[ 4.147039] amdgpu 0000:01:00.0: fence driver on ring 2 use gpu addr 0x0000000100000028, cpu addr 0xffff9772a5738028
[ 4.147096] amdgpu 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000100000038, cpu addr 0xffff9772a5738038
[ 4.147155] amdgpu 0000:01:00.0: fence driver on ring 4 use gpu addr 0x0000000100000048, cpu addr 0xffff9772a5738048
[ 4.147210] amdgpu 0000:01:00.0: fence driver on ring 5 use gpu addr 0x0000000100000058, cpu addr 0xffff9772a5738058
[ 4.147270] amdgpu 0000:01:00.0: fence driver on ring 6 use gpu addr 0x0000000100000068, cpu addr 0xffff9772a5738068
[ 4.147323] amdgpu 0000:01:00.0: fence driver on ring 7 use gpu addr 0x0000000100000078, cpu addr 0xffff9772a5738078
[ 4.147379] amdgpu 0000:01:00.0: fence driver on ring 8 use gpu addr 0x0000000100000088, cpu addr 0xffff9772a5738088
[ 4.147400] amdgpu 0000:01:00.0: fence driver on ring 9 use gpu addr 0x000000010000009c, cpu addr 0xffff9772a573809c
[ 4.149180] amdgpu 0000:01:00.0: fence driver on ring 10 use gpu addr 0x00000001000000ac, cpu addr 0xffff9772a57380ac
[ 4.149254] amdgpu 0000:01:00.0: fence driver on ring 11 use gpu addr 0x00000001000000bc, cpu addr 0xffff9772a57380bc
[ 4.153106] amdgpu 0000:01:00.0: fence driver on ring 12 use gpu addr 0x0000000000a2d420, cpu addr 0xffffa53bc2e5a420
[ 4.158356] amdgpu 0000:01:00.0: fence driver on ring 13 use gpu addr 0x00000001000000dc, cpu addr 0xffff9772a57380dc
[ 4.158432] amdgpu 0000:01:00.0: fence driver on ring 14 use gpu addr 0x00000001000000ec, cpu addr 0xffff9772a57380ec
[ 4.220416] amdgpu: [powerplay] [AVFS] Something is broken. See log!
[ 4.223254] amdgpu: [powerplay] Can't find requested voltage id in vdd_dep_on_sclk table!
[ 4.226914] amdgpu: [powerplay]
[ 4.226930] amdgpu: [powerplay]
[ 4.951957] fbcon: amdgpudrmfb (fb0) is primary device
[ 4.997987] amdgpu 0000:01:00.0: fb0: amdgpudrmfb frame buffer device
[ 5.027002] [drm] Initialized amdgpu 3.18.0 20150101 for 0000:01:00.0 on minor 0

...i tried the TearFree option to be 'on' but it had no effect - there is no further custom configuration made.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 02 April 2018, 17:19 GMT
Reason for closing:  None
Additional comments about closing:  Cannot reproduce.
Comment by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 13:01 GMT
Is this still an issue? We had lots of related updates.
Comment by Milan (verymilan) - Sunday, 01 April 2018, 19:37 GMT
Hi, sorry, i can't check as i sold my card and got me an nvidia card some time after reporting this issue.

Loading...