Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55962 - [glib2] 2.54.1-2 assertion fails (causes kernel to not boot)

Attached to Project: Arch Linux
Opened by Cookie Engineer (cookiengineer) - Thursday, 12 October 2017, 09:29 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 16 October 2017, 14:33 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The current version of glib2 causes assertion failures that will eventually cause the bootup procedure to not work. The system bootup screen will show "[failed] kernel modules", and journalctl -xe will show some assertion failures for glib2.

A downgrade to glib2 version 2.54.1-1 fixed the problem on three of my systems (Intel NUC 3rd gen, Dell Latitude E4300 and Intel core2duo extreme with AMD Radeon PCI-X card).

On all systems I had to reinstall the linux package (and let DKMS rebuild everything) in order to unbrick the systems. Afterwards everything worked fine.

Additional info:
* package version 2.54.1-2
* default config (via pacman)


Steps to reproduce:

- Install glib2 version 2.54.1-2 on system
- Reboot
- Problem occurs, journalctl -xe | grep glib will show assertion errors
- Downgrade glib2 to version 2.54.1-1
- Reboot
- If it still does not work (on two of my machines that was the case), reinstall linux or let DKMS rebuild all modules.
- Now system is working again


PS:
I have no idea what caused these errors in particular, but leaving every package at the same version, except glib2, fixed the problem. Therefore I would guess it was the cause of the problem.

I also have no idea how to do a proper kernel stacktrace for this problem, if that is needed. I would like to offer one if necessary; if you could instruct me on what to do.

This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 16 October 2017, 14:33 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Thursday, 12 October 2017, 15:06 GMT
I don't buy it. I could see it stopping the graphical env from coming up, but not the system booting at all, and certainly not kernel modules from loading.
Comment by Doug Newgard (Scimmia) - Sunday, 15 October 2017, 13:45 GMT
And with no other votes and nobody else watching this, it's a very safe bet that this is bogus. Unless you have more information?

Loading...