Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55956 - [plasma-workspace] Regression: cannot switch users. Fix available

Attached to Project: Arch Linux
Opened by Moabit (Moabit) - Wednesday, 11 October 2017, 21:39 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 12 October 2017, 08:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

plasma-workspace 5.11.0-1 prevents user switching. This is a known regression [a]. The developer reverted the guilty commit for the next release, but in the meantime, I can confirm that patching /usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/components/UserDelegate.qml [b] solves this problem.

[a] https://forum.kde.org/viewtopic.php?f=289&t=142444
[b] https://github.com/KDE/plasma-workspace/commit/ac40f7dec47df9c48fa55d90be67ea4cbebcb09d
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 12 October 2017, 08:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  plasma-workspace 5.11.0-2
Comment by Eli Schwartz (eschwartz) - Wednesday, 11 October 2017, 22:21 GMT
From the thread: "I just reverted the breaking commit. Plasma 5.11.1 to be released next Tuesday will contain this fix. Sorry about that."

I don't know that this will merit a backport considering the impending release and the non-critical nature of this bug.
Comment by Moabit (Moabit) - Wednesday, 11 October 2017, 22:26 GMT
Okay, fair enough. FWIW it's critical for me (and potentially others?), because the other users can't use the computer!

Loading...