Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55871 - texlive-core 2017.44918-1 (pdflatex, latex, etc.) fails with poppler 0.60.0

Attached to Project: Arch Linux
Opened by diego sevilla (dsevilla) - Wednesday, 04 October 2017, 23:18 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 05 October 2017, 02:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: whenever you run any utility in texlive-core (pdflatex, latex, etc.) it fails with a missing symbol: _ZN6Object11getTypeNameEv. Tracking the library that defined something similar, I've seen poppler recently changed from 0.59 to 0.60, and in the code it seems this particular function changed from non-const to const, causing the symbol to be different and a missing link symbol. Recompiling the texlive-core package with the new poppler 0.60 may solve the issue, but at the moment, any texlive-core program that use poppler is failing.


Additional info:
* package version(s) poppler 0.60.0, texlive-core 2017.44918-1
* config and/or log files etc.


Steps to reproduce: Execute pdflatex with these packages and versions.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 05 October 2017, 02:13 GMT
Reason for closing:  Deferred
Additional comments about closing:  See comments
Comment by loqs (loqs) - Wednesday, 04 October 2017, 23:23 GMT
Duplicate of  FS#55867  ?
Comment by Gaetan Bisson (vesath) - Thursday, 05 October 2017, 02:07 GMT
It appears poppler-0.60.0 was pushed to [testing] by mistake: it requires a proper rebuild of packages that depend on it, which is underway. You can expect an updated [testing] tomorrow or so.
Comment by Doug Newgard (Scimmia) - Thursday, 05 October 2017, 02:12 GMT
Poppler didn't bump the soname, so the ABI shouldn't have changed. Someone upstream screwed up. Anyway, like vesath said, rebuild is in progress.

Loading...