Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55849 - [kdenlive] Won't start

Attached to Project: Arch Linux
Opened by farid (osc) - Tuesday, 03 October 2017, 15:39 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 03 October 2017, 22:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After an update Kdenlive wont start anymore. I need this for work, hence the severity. :)

Additional info:

Using kdenlive and mlt from repos.

Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DoubleBuffer), swapInterval 1, profile QSurfaceFormat::OpenGLContextProfile(NoProfile))

Thread 1 "kdenlive" received signal SIGABRT, Aborted.
0x00007ffff039a8a0 in raise () from /usr/lib/libc.so.6
(gdb) thread apply all bt

Thread 12 (Thread 0x7fff913df700 (LWP 12998)):
#0 0x00007fffee47638d in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1 0x00007ffff0e9d5cc in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2 0x00007ffff0e95cec in QSemaphore::acquire(int) () at /usr/lib/libQt5Core.so.5
#3 0x00005555558da575 in ()
#4 0x00007ffff6fd8c9e in mlt_events_fire () at /usr/lib/libmlt.so.6
#5 0x00007ffff6fe2977 in mlt_consumer_rt_frame () at /usr/lib/libmlt.so.6
#6 0x00007fffa256d3a4 in () at /usr/lib/mlt/libmltsdl.so
#7 0x00007fffee47008a in start_thread () at /usr/lib/libpthread.so.0
#8 0x00007ffff045c1bf in clone () at /usr/lib/libc.so.6

Thread 10 (Thread 0x7fff937fe700 (LWP 12996)):
#0 0x00007ffff0451cbb in poll () at /usr/lib/libc.so.6
#1 0x00007fffe79d6c09 in () at /usr/lib/libglib-2.0.so.0
#2 0x00007fffe79d6d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3 0x00007ffff10da041 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4 0x00007ffff107dfdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5 0x00007ffff0e973ee in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6 0x00007ffff22b43d9 in () at /usr/lib/libQt5Qml.so.5
#7 0x00007ffff0e9c13b in () at /usr/lib/libQt5Core.so.5
#8 0x00007fffee47008a in start_thread () at /usr/lib/libpthread.so.0
#9 0x00007ffff045c1bf in clone () at /usr/lib/libc.so.6

Thread 9 (Thread 0x7fff93fff700 (LWP 12995)):
#0 0x00007fffee4766cd in pthread_cond_timedwait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1 0x00007ffff0e9d481 in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2 0x00007ffff0e98566 in () at /usr/lib/libQt5Core.so.5
#3 0x00007ffff0e9c13b in () at /usr/lib/libQt5Core.so.5
#4 0x00007fffee47008a in start_thread () at /usr/lib/libpthread.so.0
#5 0x00007ffff045c1bf in clone () at /usr/lib/libc.so.6

Thread 8 (Thread 0x7fff99916700 (LWP 12994)):
#0 0x00007ffff0451cbb in poll () at /usr/lib/libc.so.6
#1 0x00007fffe79d6c09 in () at /usr/lib/libglib-2.0.so.0
#2 0x00007fffe79d6d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#3 0x00007ffff10da041 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4 0x00007ffff107dfdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5 0x00007ffff0e973ee in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6 0x00007ffff22b43d9 in () at /usr/lib/libQt5Qml.so.5
#7 0x00007ffff0e9c13b in () at /usr/lib/libQt5Core.so.5
#8 0x00007fffee47008a in start_thread () at /usr/lib/libpthread.so.0
#9 0x00007ffff045c1bf in clone () at /usr/lib/libc.so.6

Thread 7 (Thread 0x7fffa4b15700 (LWP 12968)):
#0 0x00007ffff0451cbb in poll () at /usr/lib/libc.so.6
#1 0x00007fffab545d31 in () at /usr/lib/libusb-1.0.so.0
#2 0x00007fffee47008a in start_thread () at /usr/lib/libpthread.so.0
#3 0x00007ffff045c1bf in clone () at /usr/lib/libc.so.6

Thread 6 (Thread 0x7fffc7fff700 (LWP 12967)):
#0 0x00007ffff0451cbb in poll () at /usr/lib/libc.so.6
#1 0x00007fffe79d6c09 in () at /usr/lib/libglib-2.0.so.0
#2 0x00007fffe79d6d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3 0x00007ffff10da041 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4 0x00007ffff107dfdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5 0x00007ffff0e973ee in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6 0x00007ffff3bd5376 in () at /usr/lib/libQt5DBus.so.5
#7 0x00007ffff0e9c13b in () at /usr/lib/libQt5Core.so.5
#8 0x00007fffee47008a in start_thread () at /usr/lib/libpthread.so.0
#9 0x00007ffff045c1bf in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7fffce286700 (LWP 12966)):
#0 0x00007ffff0451cbb in poll () at /usr/lib/libc.so.6
#1 0x00007fffe79d6c09 in () at /usr/lib/libglib-2.0.so.0
#2 0x00007fffe79d6fa2 in g_main_loop_run () at /usr/lib/libglib-2.0.so.0
#3 0x00007fffe51ad546 in () at /usr/lib/libgio-2.0.so.0
#4 0x00007fffe79fdae5 in () at /usr/lib/libglib-2.0.so.0
#5 0x00007fffee47008a in start_thread () at /usr/lib/libpthread.so.0
#6 0x00007ffff045c1bf in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7fffcea87700 (LWP 12965)):
---Type <return> to continue, or q <return> to quit---
#0 0x00007ffff0451cbb in poll () at /usr/lib/libc.so.6
#1 0x00007fffe79d6c09 in () at /usr/lib/libglib-2.0.so.0
#2 0x00007fffe79d6d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3 0x00007fffe79d6d61 in () at /usr/lib/libglib-2.0.so.0
#4 0x00007fffe79fdae5 in () at /usr/lib/libglib-2.0.so.0
#5 0x00007fffee47008a in start_thread () at /usr/lib/libpthread.so.0
#6 0x00007ffff045c1bf in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7fffd7e11700 (LWP 12964)):
#0 0x00007ffff0451cbb in poll () at /usr/lib/libc.so.6
#1 0x00007fffe70fc8e0 in () at /usr/lib/libxcb.so.1
#2 0x00007fffe70fe679 in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3 0x00007fffda59674a in () at /usr/lib/libQt5XcbQpa.so.5
#4 0x00007ffff0e9c13b in () at /usr/lib/libQt5Core.so.5
#5 0x00007fffee47008a in start_thread () at /usr/lib/libpthread.so.0
#6 0x00007ffff045c1bf in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7fffdb75b700 (LWP 12963)):
#0 0x00007fffee47638d in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1 0x00007ffff0b1c48d in __gthread_cond_wait (__mutex=<optimized out>, __cond=<optimized out>)
at /build/gcc/src/gcc-build/x86_64-pc-linux-gnu/libstdc++-v3/include/x86_64-pc-linux-gnu/bits/gthr-default.h:864
#2 0x00007ffff0b1c48d in std::condition_variable::wait(std::unique_lock<std::mutex>&) (this=<optimized out>, __lock=...)
at /build/gcc/src/gcc/libstdc++-v3/src/c++11/condition_variable.cc:53
#3 0x00007fffed4f53f7 in () at /usr/lib/libQt5WebKit.so.5
#4 0x00007fffed4f5539 in () at /usr/lib/libQt5WebKit.so.5
#5 0x00007ffff0b22a6f in std::execute_native_thread_routine(void*) (__p=0x555555e1e600)
at /build/gcc/src/gcc/libstdc++-v3/src/c++11/thread.cc:83
#6 0x00007fffee47008a in start_thread () at /usr/lib/libpthread.so.0
#7 0x00007ffff045c1bf in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7ffff7f098c0 (LWP 12959)):
#0 0x00007ffff039a8a0 in raise () at /usr/lib/libc.so.6
#1 0x00007ffff039bf09 in abort () at /usr/lib/libc.so.6
#2 0x00007ffff0e86988 in () at /usr/lib/libQt5Core.so.5
#3 0x00007ffff27590ab in QSGRenderLoop::handleContextCreationFailure(QQuickWindow*, bool) () at /usr/lib/libQt5Quick.so.5
#4 0x00007ffff275a0f2 in () at /usr/lib/libQt5Quick.so.5
---Type <return> to continue, or q <return> to quit---
#5 0x00007ffff275ad4a in () at /usr/lib/libQt5Quick.so.5
#6 0x00007ffff15ea4b5 in QWindow::event(QEvent*) () at /usr/lib/libQt5Gui.so.5
#7 0x00007ffff27d0936 in QQuickWindow::event(QEvent*) () at /usr/lib/libQt5Quick.so.5
#8 0x00007ffff2d6ee2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#9 0x00007ffff2d76906 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#10 0x00007ffff107fbb0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#11 0x00007ffff15df123 in QGuiApplicationPrivate::processExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*) ()
at /usr/lib/libQt5Gui.so.5
#12 0x00007ffff15dfd9e in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
at /usr/lib/libQt5Gui.so.5
#13 0x00007ffff15b748c in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
at /usr/lib/libQt5Gui.so.5
#14 0x00007fffda5face1 in () at /usr/lib/libQt5XcbQpa.so.5
#15 0x00007fffe79d6a57 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#16 0x00007fffe79d6c88 in () at /usr/lib/libglib-2.0.so.0
#17 0x00007fffe79d6d1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#18 0x00007ffff10da041 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#19 0x00007ffff107dfdb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#20 0x00007ffff1087028 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#21 0x00005555555fd8d0 in ()
#22 0x00007ffff0386f6a in __libc_start_main () at /usr/lib/libc.so.6
#23 0x00005555555fe0ea in _start ()


Steps to reproduce:
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 03 October 2017, 22:06 GMT
Reason for closing:  Not a bug
Comment by farid (osc) - Tuesday, 03 October 2017, 16:05 GMT
Terminal message:

$ kdenlive
QGLXContext: Failed to create dummy context
Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DoubleBuffer), swapInterval 1, profile QSurfaceFormat::OpenGLContextProfile(NoProfile))
Abortado (imagem do nĂșcleo gravada)
Comment by Antonio Rojas (arojas) - Tuesday, 03 October 2017, 21:56 GMT
Your opengl is broken, nothing to do with kdenlive. Check your drivers.
Comment by farid (osc) - Tuesday, 03 October 2017, 22:03 GMT
I updated nvidia and didn't restart/reload. Fixed by restarting the system.

Thanks.

Loading...