Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55837 - [chromium] does not work at all

Attached to Project: Arch Linux
Opened by Jan Krcmar (honza801) - Monday, 02 October 2017, 08:29 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 27 February 2018, 09:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

hi,

Description:
after chromium starts, window renders correctly. but does not respond to keyboard/mouse input. new-page is loaded, but does not respond. menu responds correctly, but nothing happens after click on items (fe. settings). "exit" item works. tabs can be closed with cross icon. reload and stop icon are swapping between states like mad :)

i've tried downgrade to 60.0.3112.90-1, but does not work correctly either.

could be some problem with libraries ???

Additional info:
* 61.0.3163.100-1

Steps to reproduce:
* start chromium

please fix,

thanks
jan
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 27 February 2018, 09:53 GMT
Reason for closing:  Works for me
Additional comments about closing:  Possibly resolved with newer Chromium versions (and/or graphics stack). Not something I was able to repro in the past.
Comment by Adam Purkrt (renergy) - Monday, 02 October 2017, 13:49 GMT
Have you tried it with a clean profile? chromium works for me just fine..
Comment by Jan Krcmar (honza801) - Tuesday, 03 October 2017, 06:20 GMT
yes, i've also deleted (moved) ~/.config/chromium and ~/.cache/chromium

i forgot to mention in details. sorry.
Comment by Doug Newgard (Scimmia) - Tuesday, 03 October 2017, 16:01 GMT
What GTK3 version and theme?
Comment by Jan Krcmar (honza801) - Wednesday, 04 October 2017, 06:31 GMT
local/gtk3 3.22.21-1

how do i get my gtk theme?

thanks,
jan
Comment by Doug Newgard (Scimmia) - Wednesday, 04 October 2017, 06:57 GMT Comment by Jan Krcmar (honza801) - Wednesday, 04 October 2017, 07:09 GMT
i don't have any of the files
GTK+ 3 user specific: $XDG_CONFIG_HOME/gtk-3.0/settings.ini, or $HOME/.config/gtk-3.0/settings.ini if $XDG_CONFIG_HOME is not set
GTK+ 3 system wide: /etc/gtk-3.0/settings.ini

i've tried to create
cat > $HOME/.config/gtk-3.0/settings.ini
[Settings]
gtk-icon-theme-name = Adwaita
gtk-theme-name = Adwaita
gtk-font-name = DejaVu Sans 11

but did not helped
Comment by Craig Barnes (cbb) - Thursday, 05 October 2017, 01:55 GMT
I have the same problem. Chromium starts, but keyboard input either doesn't work at all or lags (by about 30 seconds). Extension icons also flash/flicker sporadically.

It seemed to happen right after installing the libinput 1.8.3 update for me. I've tried reinstalling the chromium package and deleting ~/.config/chromium/, ~/.cache/chromium/ and /etc/chromium/policies/, but the problem still persists.
Comment by Craig Barnes (cbb) - Thursday, 05 October 2017, 15:24 GMT
I just removed all of the Chromium config and cache directories again, and this time also removed /etc/chromium/ completely. After reinstalling the chromium package, it now seems to work. I have also reinstalled my custom configs and policy files as before and it still seems to work fine. No idea what could have been causing the problems.
Comment by Jan Krcmar (honza801) - Sunday, 08 October 2017, 15:57 GMT
  • Field changed: Percent Complete (100% → 0%)
i don't have /etc/chromium/, so cannot remove. i've tried chromium reinstall and delete ~/.config/chromium, ~/.cache/chromium again. i've also upgraded libinput (1.8.2-1 -> 1.8.3-1). nothing helped.
Comment by Tobias (ttilter) - Saturday, 14 October 2017, 11:02 GMT
I have had the same problem. Solved it by turning hardware acceleration off. The problem reoccurs when I switch it back on.

If someone knows how to turn hardware acceleration off without using chromium, please say so. It might help the others. I managed to do it using chromium by moving it between two fixed window containers in my tiling window manager. In this way, chromium sometimes correctly updated the window.
Comment by Friedrich Strohmaier (bitsfritz) - Thursday, 19 October 2017, 00:11 GMT
I confirm Tobias solution.

Same Problem. Solved by turning off hardware acceleration.
Same Question: how to turn off hardware acceleration apart from using Chromium?

Got Chromium response after restarting (xfce-)desktop environment.

~]# lspci | grep Display
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

~]$ chromium -h
Chromium launcher v5 -- for Chromium help, see chromium(1)
Custom flags are read from the following file:
/home/<my home>/.config/chromium-flags.conf

What's the name of the flag?
Comment by Jan Krcmar (honza801) - Thursday, 19 October 2017, 07:20 GMT
i'm running

chromium --disable-gpu

chromium then works. but all the load goes to cpu. it would be good NOT TO bypass gpu acceleration since it offers much better performance.
Comment by Evangelos Foutras (foutrelis) - Thursday, 25 January 2018, 10:30 GMT
Is this still an issue and is it reproducible with Google Chrome as well?
Comment by Tobias (ttilter) - Thursday, 25 January 2018, 12:05 GMT
Not an issue for me any longer. Can't reproduce it anymore - neither with chromium nor with chrome.

Loading...