Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55833 - [thunderbird] Might need rebuild against nss=3.33-1

Attached to Project: Arch Linux
Opened by Jonathon (jonathon) - Sunday, 01 October 2017, 22:49 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 03 October 2017, 15:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Password storage appears to have been broken by nss=3.33-1. This can be seen in Thunderbird if a Master Password has been set, or server passwords are stored in Password Manager. On launch, Thunderbird no longer prompts for a Master Password, and does not use stored passwords for server login.

There is no related output when launched from a terminal (output I get is about Lightning calendars).

I'm rebuilding to confirm the cause but wanted to flag this in case this is a "previously known issue".

(This might also affect Firefox.)

Additional info:
* thunderbird=52.3.0-2
* nss=3.33-1

Steps to reproduce:
* Update to nss>=3.33
* Launch Thunderbird:

1)
- Observe lack of Master Password prompt

2)
- Attempt to log in to mail server using credentials stored in Password Manager
- Observe prompt for server-specific password
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 03 October 2017, 15:19 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Corrupt database
Comment by Jonathon (jonathon) - Sunday, 01 October 2017, 23:12 GMT
Rebuild against nss=3.33-1 didn't make any difference so I'm at a loss...
Comment by Jonathon (jonathon) - Monday, 02 October 2017, 11:00 GMT
Looks like it's an issue with `secmod.db` within the Thunderbird profile. After (re)moving this file it is recreated by Thunderbird. Thunderbird then asks correctly for a Master Password, and stored passwords are available.

Loading...