Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55832 - [networkmanager-openvpn] Cannot Alter/Add Configuration

Attached to Project: Arch Linux
Opened by M.Reynolds (TheChickenMan) - Sunday, 01 October 2017, 21:13 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 07 October 2017, 04:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Since the most recent update I have been unable to update configuration settings for OpenVPN through Network Manager using the settings application in gnome or using nm-connection-editor. I had still been able to make connections using settings which were pre-existing since the update but once attempting to change them from inside Network Manager this becomes impossible. It also will not allow for a new connection to be correctly created if I delete the old settings. OpenVPN itself appears to be working as I can connect manually using the terminal.

Additional info:
libnm 1.8.4-1
libnm-glib 1.8.4-1
networkmanager 1.8.4-1
networkmanager-openvpn 1.8.0-1
nm-connection-editor 1.8.4-1
openvpn 2.4.4-1

Steps to reproduce:
1. Open gnome settings application or nm-connection-editor and attempt to edit settings on an existing OpenVPN connection.
2. Go to "identity" page where the certificate files are entered.
3. I was using "password with certificates (TLS).
4. Attempt to make changes to CA or user certificate
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 07 October 2017, 04:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  networkmanager-openvpn 1.8.1dev+10+ge4d8cda-1
Comment by Przemek B (pcfighter) - Tuesday, 03 October 2017, 07:29 GMT
I can confirm the bug. Just after saving, when you open configuration once more I see that my CA certificate was on private user cert too.

Logs shows following information:

nm-openvpn[29737]: Options error: If you use one of --cert or --key, you must use them both

Probably there is a bug with saving configuration so openvpn cannot start.
Comment by nammidd (nammidd) - Tuesday, 03 October 2017, 08:22 GMT
Confirm the bug.
Comment by Dan Pasanen (invisiblek) - Tuesday, 03 October 2017, 15:08 GMT
Building networkmanager-openvpn on the latest HEAD (4faaa4d8066642d1d709bdfc8774e4e8651b9035 as of right now) fixes it. I suspect this is the actual fix: https://git.gnome.org/browse/network-manager-openvpn/commit/?id=b83f028a6da067dcc9b31555c15411f0288ebda1
Comment by M.Reynolds (TheChickenMan) - Thursday, 05 October 2017, 11:47 GMT
With the updated package I have noted that file names for configuration do seem to be saving but it's still failing to actually "work".
Has anyone else had any luck? I'm not 100% sure anymore if it's not some additional setting I messed up while trying to get it to work the other day.

$nmcli c up ExpressVPN
Error: Connection activation failed: The VPN service stopped unexpectedly
Comment by Przemek B (pcfighter) - Thursday, 05 October 2017, 16:52 GMT
Works for me just fine after building and installing package (used package networkmanager-openvpn-git from AUR).
Comment by M.Reynolds (TheChickenMan) - Friday, 06 October 2017, 22:41 GMT
I checked my kernel message log and I'm getting this now (since the latest networkmanager-openvpn update) when I try to start my vpn.
gnome-control-c[1399]: segfault at 0 ip 00007f5f37482ca7 sp 00007ffff1de4020 error 4 in libnm.so.0.1.0[7f5f37435000+de000]

Loading...