Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55827 - [eog] Segfaults on launch

Attached to Project: Arch Linux
Opened by Mantas (sirex) - Sunday, 01 October 2017, 17:32 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 02 October 2017, 19:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: eog does not start and gives segmentation fault.


Additional info:
* package version: 3.24.1-1

Output of `coredumpctl info eog`:

PID: 29233 (eog)
UID: 1000 (sirex)
GID: 100 (users)
Signal: 11 (SEGV)
Timestamp: Sun 2017-10-01 20:25:09 EEST (27s ago)
Command Line: eog
Executable: /usr/bin/eog
Control Group: /user.slice/user-1000.slice/user@1000.service/gnome-terminal-server.service
Unit: user@1000.service
User Unit: gnome-terminal-server.service
Slice: user-1000.slice
Owner UID: 1000 (sirex)
Boot ID: a44c11087e4f4d97b731a5a9b0eaf6a0
Machine ID: 8453d3ab4db84c78abbb1a3404e98b95
Hostname: sirex-t450
Storage: /var/lib/systemd/coredump/core.eog.1000.a44c11087e4f4d97b731a5a9b0eaf6a0.29233.1506878709000000.lz4
Message: Process 29233 (eog) of user 1000 dumped core.

Stack trace of thread 29233:
#0 0x00007f65f08b461c n/a (libexiv2.so.26)
#1 0x00007f65f088ed8d n/a (libexiv2.so.26)
#2 0x00007f65f087dc85 _ZN8TXMPMetaINSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEE17RegisterNamespaceEPKcS8_ (libexiv2.so.26)
#3 0x00007f65f08792f8 _ZN5Exiv29XmpParser10initializeEPFvPvbES1_ (libexiv2.so.26)
#4 0x00007f65f0bf4e0e gexiv2_initialize (libgexiv2.so.2)
#5 0x00007f6609af91c8 ffi_call_unix64 (libffi.so.6)
#6 0x00007f6609af8c2a ffi_call (libffi.so.6)
#7 0x00007f65f32f497c n/a (_gi.cpython-36m-x86_64-linux-gnu.so)
#8 0x00007f65f32f6468 n/a (_gi.cpython-36m-x86_64-linux-gnu.so)
#9 0x00007f65f3bdebf4 _PyObject_FastCallDict (libpython3.6m.so.1.0)
#10 0x00007f65f3c1b95d n/a (libpython3.6m.so.1.0)
#11 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#12 0x00007f65f3c1bda7 PyEval_EvalCodeEx (libpython3.6m.so.1.0)
#13 0x00007f65f3bb8feb PyEval_EvalCode (libpython3.6m.so.1.0)
#14 0x00007f65f3bb07ca n/a (libpython3.6m.so.1.0)
#15 0x00007f65f3c1dd30 PyCFunction_Call (libpython3.6m.so.1.0)
#16 0x00007f65f3bbe58c _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#17 0x00007f65f3c1a173 n/a (libpython3.6m.so.1.0)
#18 0x00007f65f3c1b571 n/a (libpython3.6m.so.1.0)
#19 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#20 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#21 0x00007f65f3c1b34a n/a (libpython3.6m.so.1.0)
#22 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#23 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#24 0x00007f65f3c1b34a n/a (libpython3.6m.so.1.0)
#25 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#26 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#27 0x00007f65f3c1b34a n/a (libpython3.6m.so.1.0)
#28 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#29 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#30 0x00007f65f3c1b34a n/a (libpython3.6m.so.1.0)
#31 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#32 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#33 0x00007f65f3c1a173 n/a (libpython3.6m.so.1.0)
#34 0x00007f65f3c1b571 n/a (libpython3.6m.so.1.0)
#35 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#36 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#37 0x00007f65f3c1a173 n/a (libpython3.6m.so.1.0)
#38 0x00007f65f3c1b571 n/a (libpython3.6m.so.1.0)
#39 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#40 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#41 0x00007f65f3c1b34a n/a (libpython3.6m.so.1.0)
#42 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#43 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#44 0x00007f65f3c1b34a n/a (libpython3.6m.so.1.0)
#45 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#46 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#47 0x00007f65f3c1b34a n/a (libpython3.6m.so.1.0)
#48 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#49 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#50 0x00007f65f3c1b34a n/a (libpython3.6m.so.1.0)
#51 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#52 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#53 0x00007f65f3c1b34a n/a (libpython3.6m.so.1.0)
#54 0x00007f65f3c1b8ee n/a (libpython3.6m.so.1.0)
#55 0x00007f65f3bb92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#56 0x00007f65f3c1adba _PyFunction_FastCallDict (libpython3.6m.so.1.0)
#57 0x00007f65f3bdedce _PyObject_FastCallDict (libpython3.6m.so.1.0)
#58 0x00007f65f3bdf70e _PyObject_CallMethodIdObjArgs (libpython3.6m.so.1.0)
#59 0x00007f65f3bfcaf4 PyImport_ImportModuleLevelObject (libpython3.6m.so.1.0)
#60 0x00007f65f3bc00d8 n/a (libpython3.6m.so.1.0)
#61 0x00007f65f3c1dcc6 PyCFunction_Call (libpython3.6m.so.1.0)
#62 0x00007f65f3bbe58c _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
#63 0x00007f65f3c1a173 n/a (libpython3.6m.so.1.0)

Stack trace of thread 29235:
#0 0x00007f660dea7cbb __poll (libc.so.6)
#1 0x00007f660e3dbc09 n/a (libglib-2.0.so.0)
#2 0x00007f660e3dbd1c g_main_context_iteration (libglib-2.0.so.0)
#3 0x00007f660e3dbd61 n/a (libglib-2.0.so.0)
#4 0x00007f660e402ae5 n/a (libglib-2.0.so.0)
#5 0x00007f660e17a08a start_thread (libpthread.so.0)
#6 0x00007f660deb21bf __clone (libc.so.6)

Stack trace of thread 29234:
#0 0x00007f660dea7cbb __poll (libc.so.6)
#1 0x00007f660e3dbc09 n/a (libglib-2.0.so.0)
#2 0x00007f660e3dbd1c g_main_context_iteration (libglib-2.0.so.0)
#3 0x00007f6601d1155d n/a (libdconfsettings.so)
#4 0x00007f660e402ae5 n/a (libglib-2.0.so.0)
#5 0x00007f660e17a08a start_thread (libpthread.so.0)
#6 0x00007f660deb21bf __clone (libc.so.6)

Stack trace of thread 29236:
#0 0x00007f660dea7cbb __poll (libc.so.6)
#1 0x00007f660e3dbc09 n/a (libglib-2.0.so.0)
#2 0x00007f660e3dbfa2 g_main_loop_run (libglib-2.0.so.0)
#3 0x00007f660ebf7546 n/a (libgio-2.0.so.0)
#4 0x00007f660e402ae5 n/a (libglib-2.0.so.0)
#5 0x00007f660e17a08a start_thread (libpthread.so.0)
#6 0x00007f660deb21bf __clone (libc.so.6)

Steps to reproduce:

Simply star `eog` command from terminal and you will get this ouptut:

> eog
[1] 29365 segmentation fault (core dumped) eog
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 02 October 2017, 19:26 GMT
Reason for closing:  Not a bug
Additional comments about closing:  OP request: caused by user-installed plugin
Comment by Cedric Bellegarde (gnumdk) - Monday, 02 October 2017, 08:04 GMT
Not happening here and EOG is not a python program. You must have a segfaulting plugin enabled.

BTW a python plugin should not segfault and issue looks similar to: https://bugs.archlinux.org/task/55779?project=1&opened=6029
Comment by Cedric Bellegarde (gnumdk) - Monday, 02 October 2017, 08:08 GMT
Please try to build https://adishatz.org/pyobject-fixed.tgz and see if it fixes the issue, if so, it's same issue than: https://bugs.archlinux.org/task/55779
Comment by Mantas (sirex) - Monday, 02 October 2017, 16:58 GMT
I turned out, that segfault was caused by 360° panorama plugin [1]. After removing this plugin eog started to work again. Sorry for the false alarm.

[1] http://www.omgubuntu.co.uk/2017/02/panorama-image-viewer-ubuntu-360-photos

Loading...