Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55812 - [nvidia] PLEASE ENTER SUMMARY

Attached to Project: Arch Linux
Opened by BoBeR182 (BoBeR182) - Saturday, 30 September 2017, 05:54 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 30 September 2017, 11:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Today, I saw there were a lot of packages due for updating (including the kernel), so I updated them all and rebooted. So far, so good.

When I boot my computer up, it shows the TTY login prompt, and I usually log in and start X manually if I want or have to.

However, upon turning it back on, I was presented with this: https://i.stack.imgur.com/yo5U6.jpg

Null characters appearing on their own, one every eight tenths of a second or so. And they're not being simply printed, they are appearing into the stdin. I can't log in, because I can't type my password, because I can't see when those pop up so I can erase them and finish the password. And no, I can't type 35 characters in eight tenths of a second.

First thought: keyboard is bad. Got rid of all input devices and powercycled. Nothing.

Second idea: system is bad. Logged in via SSH from my phone. No null characters to speak of. I can use the terminal normally from here. But not physically. Something to do with tty specifically?

All in all, I'm "locked out" of my computer (SSH works, so there's that) and all out of ideas.

And the null characters don't stop coming: https://i.stack.imgur.com/wjlVw.jpg
If I run xev to see if keystrokes are being detected... guess what:

KeyRelease event, serial 42, synthetic NO, window 0x2200001,
root 0x29e, subw 0x0, time 5986026, (15,93), root:(996,809),
state 0x50, keycode 221 (keysym 0x0, NoSymbol), same_screen YES,
XLookupString gives 0 bytes:
XFilterEvent returns: False

Every single program I open is getting these. And the time info in xev output says EXACTLY 800 ms of interval, always ending in "26". Which means, these ^@ are being sent every 0.8 seconds, down to the millisecond, since I turned my computer back on. No change in period, no drift, no nothing.

Steps to reproduce:
Open a TTY
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 30 September 2017, 11:52 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#55803 
Comment by Darek (blablo) - Saturday, 30 September 2017, 08:27 GMT Comment by Darek (blablo) - Saturday, 30 September 2017, 09:00 GMT Comment by Darek (blablo) - Saturday, 30 September 2017, 09:05 GMT

Loading...