Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55809 - [linux 4.13.3-1] unable to mount samba share

Attached to Project: Arch Linux
Opened by hopimet (hopimet) - Friday, 29 September 2017, 16:59 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 30 September 2017, 12:11 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I have a samba share on a raspberry pi running with debian jessie. On my laptop with archlinux, I used to mount this samba share with the following command line:
sudo mount -t cifs -o username=xxx,uid=1000,gid=100,iocharset=utf8,sec=ntlm //192.168.0.xxx/xxx /home/xxx/xxx
It worked fine until the recent upgrade to kernel 4.13.3-1.

Now the command returns an error:
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I am convinced this is a bug of the kernel because when I boot on the lts kernel I can mount the samba share without problem. Downgrading the kernel also works.


Additional info:
* package version(s) : linux 4.13.3-1
* config and/or log files etc.


Steps to reproduce:
Boot with the kernel linux 4.13.3-1 and try to mount a samba share in console.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 30 September 2017, 12:11 GMT
Reason for closing:  Not a bug
Comment by loqs (loqs) - Friday, 29 September 2017, 17:11 GMT Comment by hopimet (hopimet) - Friday, 29 September 2017, 17:38 GMT
Thanks a lot. I didn't see this information. vers=2.1 works fine.

Loading...