Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55808 - [git-annex] Copying files to webdav backends no longer works

Attached to Project: Community Packages
Opened by Matt (madalu) - Friday, 29 September 2017, 15:35 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 06 July 2018, 03:15 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
git-annex can no longer copy files to webdav backends (e.g., Box).

This problem appeared with the upgrade to git-annex 6.20170925-1 and the simultaneous update to haskell-dav 1.3.1-158.

With this upgrade, when attempting to copy a file to box, I get the following error:

DAV failure: Status {statusCode = 405, statusMessage = "Method Not Allowed"} "<?xml version=\"1.0\" encoding=\"utf-8\"?>\n<d:error xmlns:d=\"DAV:\" xmlns:s=\"http://sabredav.org/ns\">\n <s:exception>Sabre_DAV_Exception_MethodNotAllowed</s:exception>\n <s:message>The resource you tried to create already exists</s:message>\n</d:error>\n"
CallStack (from HasCallStack):
error, called at ./Remote/WebDAV.hs:381:78 in main:Remote.WebDAV
failed
git-annex: copy: 1 failed

This is *not* an upstream bug. I reported this bug upstream to discover that it is not an upstream problem. The most upstream standalone build (6.20170929-gffc127582) works fine. See the bug report and conversation here:

https://git-annex.branchable.com/bugs/git-annex_can_no_longer_copy_files_to_box/

Additional info:
* package version(s)

git-annex 6.20170925-1
haskell-dav 1.3.1-158

* config and/or log files etc.

The webdav backed was originally set up with

WEBDAV_USERNAME=[username] WEBDAV_PASSWORD=[passwd] git annex initremote box type=webdav url=https://dav.box.com/dav/git-annex chunk=100mb keyid=[keyid]

Steps to reproduce:

Set up a webdav remote per the command above. Then with in the git annex repository add and copy a file to webdav.

git-annex add test.pdf
git-annex copy -t box test.pdf
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 06 July 2018, 03:15 GMT
Reason for closing:  Fixed
Comment by Matt (madalu) - Friday, 29 September 2017, 15:46 GMT
One point of clarification. The release numbers I reported above are the ones which first produced this problem. The problem has persisted for all subsequent releases of git-annex and haskell-dav.
Comment by Matt (madalu) - Thursday, 12 October 2017, 01:00 GMT
It turns out this was an upstream bug. It has been fixed in the upstream repo (as of Oct 11). So I think this bug report can be closed.

Loading...