Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55803 - [linux] keyboard is not working properly

Attached to Project: Arch Linux
Opened by Leonardo Teodoro (leoteodoro78) - Friday, 29 September 2017, 03:02 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 21 November 2017, 21:23 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

a video of the bug, may this helps more than typing a text:
https://youtu.be/84BBhHxm77M

I was using archlinux kde when this happens, kde have some problems and I though this could be something from kde, so I reinstalled archlinux and the bug persists, I think it's something from kernel because when I updated to kernel 4.13 this starts to happen...

no logs
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 21 November 2017, 21:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.14.1-1
Comment by Leonardo Teodoro (leoteodoro78) - Friday, 29 September 2017, 03:07 GMT
in this video I was tryin' to use backspace but the text wasn't erased...
at transformice.com I didn't press any button and the mouse just goes to the left...
Comment by Leonardo Teodoro (leoteodoro78) - Friday, 29 September 2017, 03:38 GMT
installed linux-lts (4.9) and everything is working fine...
Comment by Philipe Reis (phireis) - Friday, 29 September 2017, 14:27 GMT
After I upgraded to linux 4.13.3-1 (from 4.12.13-1), I had strange problems with keyboard: in any application if I press and hold backspace to delete a lof of characters, it delete only a few and stops, forcing me to press backspace many times to be able delete texts. Or any time i need to press and hold any key, to repeated a character multiples, the holding is interrupted shortly. If I change to a console prompt (CTRL-ALT-F3), I see that a strange character (something like ^@) is typed every 2 or 3 seconds, making it impossible to login in the console, it happens even if I unplug the keyboard from the machine. It seems the kernel 4.13 is somehow generating false keyboard strokes. Downgrading package linux (4.13.3-1 -> 4.12.13-1) solved the issue.
Comment by loqs (loqs) - Friday, 29 September 2017, 20:36 GMT Comment by Mijail Rondon (mijailr) - Wednesday, 04 October 2017, 05:23 GMT
The issue is solved by blacklisting input_polldev. Should this be fixed in the next release of the kernel?
Comment by loqs (loqs) - Wednesday, 04 October 2017, 16:30 GMT
@mijailr is there a patch for this?
Comment by Mijail Rondon (mijailr) - Wednesday, 04 October 2017, 23:41 GMT
@loqs maybe changing CONFIG_INPUT_POLLDEV=m to CONFIG_INPUT_POLLDEV=n in the config.x86_64 and config.i686 but i dont know if this is the best approach because this will disable input_polldev for everyone.

Something like this will work:

@@ -3333,7 +3333,7 @@
CONFIG_INPUT=y
CONFIG_INPUT_LEDS=m
CONFIG_INPUT_FF_MEMLESS=m
-CONFIG_INPUT_POLLDEV=m
+CONFIG_INPUT_POLLDEV=n
CONFIG_INPUT_SPARSEKMAP=m
CONFIG_INPUT_MATRIXKMAP=m
Comment by loqs (loqs) - Wednesday, 04 October 2017, 23:59 GMT
I don't think that will from the help text "This option is only useful for out-of-tree drivers since in-tree drivers select it automatically." https://cateee.net/lkddb/web-lkddb/INPUT_POLLDEV.html
So all in tree drivers that cause it to be selected would need to be disabled. I would suggest reporting it upstream see if there is an alternate solution.
Comment by loqs (loqs) - Sunday, 08 October 2017, 20:20 GMT Comment by Leonardo Teodoro (leoteodoro78) - Monday, 09 October 2017, 04:27 GMT
fixed!
will this be fixed in the new 4.14 kernel version?
just blacklisted input_polldev and everything works fine! :D
Comment by loqs (loqs) - Friday, 10 November 2017, 18:45 GMT
as the proposed patch does not appear to be going to make it into 4.14 as an alternative to arch taking a none upstreamed patch
CONFIG_PEAQ_WMI could be disabled which should also prevent the issue.
Comment by loqs (loqs) - Tuesday, 21 November 2017, 14:45 GMT
Can one of those affected verify the issue is fixed in linux 4.14.1-1 in testing?
Comment by Leonardo Teodoro (leoteodoro78) - Tuesday, 21 November 2017, 20:03 GMT
yes, it is!

Loading...