Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55800 - [linux] Kernel 4.13.3 cannot suspend

Attached to Project: Arch Linux
Opened by Nicolas Gruel (gruel) - Thursday, 28 September 2017, 19:33 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 11 October 2017, 16:24 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

I have thinkpad and since the update of the kernel suspend does not work (kernel 4.13.3-1)
The system is stuck and only a hard reboot solve the situation. This is new.

Additional info:
* package version(s)

Linux 4.13.3-1-ARCH #1 SMP PREEMPT Thu Sep 21 20:33:16 CEST 2017 x86_64 GNU/Linux

* config and/or log files etc.


Steps to reproduce:

- Start the computer
- suspend it

Result: Stuck in a black screen mode, Led is blinking as it is on suspend but fan still running and other led still on when normaly off in suspend.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 11 October 2017, 16:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.13.5-1
Comment by Nicolas Gruel (gruel) - Thursday, 28 September 2017, 19:38 GMT
I tried the testing version 4.13.4-1 and same result.
Comment by Kevin Dodd (Jesin) - Thursday, 28 September 2017, 20:06 GMT
Nicolas, does the PKGBUILD I uploaded in the latest comment on https://bugs.archlinux.org/task/55645 help you at all?
Comment by Nicolas Gruel (gruel) - Thursday, 28 September 2017, 20:37 GMT
I think that I am subject to the following bug:

https://bugzilla.kernel.org/show_bug.cgi?id=197029
Comment by Kevin Dodd (Jesin) - Thursday, 28 September 2017, 20:38 GMT
(I suspect it probably won't, since the symptoms you described, while similar, are not quite the same.)
Comment by Nicolas Gruel (gruel) - Wednesday, 04 October 2017, 07:36 GMT
It seems that the problem is an upstream bug which was present before but not noticeable because of the default option used by Arch. For the linux 4.13, the workaround is to use the option at start: intel_iommu=off

Perhaps a come back to that option will be good until upstream solved the problem?
Comment by Tomasz Legutko (tlegutko) - Monday, 09 October 2017, 10:13 GMT
Also had this bug and intel_iommu=off helped, thanks! Other solution posted here is to use newer kernel, as 4.13.5 (currently in testing repo) seems to have fixed it https://bugs.archlinux.org/task/55857.
Comment by Tuxle (dns2utf8) - Monday, 09 October 2017, 15:45 GMT
A side effect for me is, shutdown halt does not work too.
But shutdown reboot does for some reason.

Loading...