Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55799 - [linux] ATH10k firmware crash in 4.13.3-1

Attached to Project: Arch Linux
Opened by Mike Javorski (javmorin) - Thursday, 28 September 2017, 18:12 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 30 September 2017, 12:38 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

ath10k_pci reports firmware crash in linux-4.13.3-1
Possibly related to #55630, but is a different package version

(Possibly) Relevant Packages:
* linux-4.13.3-1
* linux-firmware-20170907.a61ac5c-1


Hardware: Dell XPS 13 (9360)

Steps to reproduce:
* install latest linux package from arch
* reboot
* firmware crash is reported at linux kernel boot
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 30 September 2017, 12:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.13.4-1
Comment by Mike Javorski (javmorin) - Thursday, 28 September 2017, 18:14 GMT
Would have re-opened #55630 but it was reported as fixed in 4.13.2-1, so this appears to be a regression.
Comment by loqs (loqs) - Thursday, 28 September 2017, 20:22 GMT
You could try linux 4.13.2-1 from the Arch Linux Archive.
Comment by Kevin Dodd (Jesin) - Thursday, 28 September 2017, 20:34 GMT
This is likely to be related to #55645, which I have already uploaded a fix for but which nobody else has commented on.
Comment by Mike Javorski (javmorin) - Thursday, 28 September 2017, 20:38 GMT
@loqs I had downgraded back to 4.12.13-1, but I downloaded/installed 4.13.2-1 and WIFI works fine, so it's definitely a regression. Now back to 4.12.13-1 as the virtualbox package doesn't support 4.13.2-1
Comment by Mike Javorski (javmorin) - Thursday, 28 September 2017, 20:43 GMT
@Jesin, I don't believe so. This issue (for me) does not result in a deadlock or unusable system, just no working WiFi. If 4.13.2-1 works for you (as it did for me) then perhaps they are two different symptoms of the same thing, but I am not a kernel dev, so I cannot say for sure.
Comment by Kevin Dodd (Jesin) - Thursday, 28 September 2017, 21:08 GMT
@javmorin, I suppose it is probably different, then.
Comment by loqs (loqs) - Thursday, 28 September 2017, 22:06 GMT
If you bisect between 4.13.2 and 4.13.3 you should be able to locate the commit that caused the regression.
There were some network related fixes in 4.13.3 https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.13.3 but I can not spot one that would obviously be the cause.
Comment by Mike Javorski (javmorin) - Thursday, 28 September 2017, 23:07 GMT
On a whim, I just tried 4.13.4-1 which is in testing right now and my ath10k WiFi works so far. Given this, the bug can be marked closed as soon as 4.13.4-1 is released.
Comment by loqs (loqs) - Thursday, 28 September 2017, 23:36 GMT
This is a strange bug: 4.13.1-1 no bug, 4.13.1-2 bug, 4.13.2-1 no bug, 4.13.3-1 bug, 4.13.4-1 no bug
Comment by Mike Javorski (javmorin) - Thursday, 28 September 2017, 23:53 GMT
If you were testing against the upstream kernel (compiling them yourself), you're right, it is odd. If you were testing with Arch kernel packages, I am starting to wonder if it's a compilation issue. Not sure who compiled each of those kernels, but I wonder if they were compiled in different environments and that is the cause of the back-and-forth.

Loading...