Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55796 - [linux-firmware] 4.13.3-1 kernel - bluetooth does not work

Attached to Project: Arch Linux
Opened by Inixi Noisse (Inixi) - Thursday, 28 September 2017, 16:10 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 11 December 2017, 16:32 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Laurent Carlier (lordheavy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description:
After upgrading kernel to linux-4.13.3-1 bluetooth stopped working correctly. After restarting bluetooth.service for the first few seconds the dongle is able to connect A2DP headphones, cannot stream any sound through that protocol and after those few seconds headphones are disconnected and following logs regarding bluetooth are generated:

kernel: Bluetooth: Failed to disable LE scan: status 0x0c
bluetoothd[455]: Control: Refusing unexpected connect
bluetoothd[455]: Suspend: Connection timed out (110)
bluetoothd[455]: Suspend: Connection timed out (110)
bluetoothd[455]: Abort: Connection timed out (110)
bluetoothd[455]: Unable to get io data for Headset Voice gateway: getpeername: Transport endpoint is not connected (107)

so I downgraded kernel to 4.12.13-1 along with dependencies and bluetooth works as it should.

my bluetooth card is:
03:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

Additional info:
* linux-4.13.3-1
* bluez 5.47-2
* bluez-libs 5.47-2
* pulseaudio-bluetooth 11.1-1

Steps to reproduce:
1. Install newest linux-4.13.3-1 with dependencies
2. Restart computer
3. Attempt to connect A2DP/HFP headphones (it was tested using Gnome 3.24.2 desktop environment with GDM3)
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 11 December 2017, 16:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux-firmware 20171206.fdee922-1
Comment by Conrad S (conrad784) - Friday, 29 September 2017, 14:21 GMT
Intel Wireless 8260 with Bluetooth
Mouse Logitech MX Master - connects over Bluetooth LE, didn't work anymore after upgrade.
If I was lucky, it did work for ~3s after new connection.
Connection to Android Phone, which can do LE and normal Bluetooth is still possible.

syslog messages which occured
bluetoothd[682]: Failed to set mode: Busy (0x0a)
bluetoothd[7315]: Unable to get io data for :1.35/Profile/HSPHSProfile/00001108-0000-1000-8000-0080/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: getpeername: Transport endpoint is not connected (107)
hci0 command 0x200c tx timeout

Is there anything I should test in detail?

Reverted back to 4.12.13-1, then everything working.
Comment by Jan Steffens (heftig) - Saturday, 30 September 2017, 19:29 GMT
Try disabling bt_coex_active on the iwlwifi module.
Comment by Pig Monkey (pigmonkey) - Saturday, 30 September 2017, 20:57 GMT
I experienced the same issue. I also am using a Intel Wireless 8260 card.

Disabling bt_coex_active fixes the problem in linux 4.13.3-1 (and linux-hardened 4.13.4.a-1, where I also experienced the problem).
Comment by Conrad S (conrad784) - Sunday, 01 October 2017, 10:10 GMT
Yes, disabling bt_coex_active fixes the problem.
Is this going to be a permanent workaround (and maybe should be added to the wiki for Bluetooth LE devices in general) or is there going to be a fix for this?
Comment by Inixi Noisse (Inixi) - Monday, 09 October 2017, 11:37 GMT
@conrad784, I would prefer not to have it as a permanent workaround, because when using wifi and bluetooth it causes a lot of skipping audio chunks when having dongle close to the headset...
Comment by Guy de Pourtal├Ęs (depourtales) - Sunday, 15 October 2017, 15:19 GMT
Experienced the same issue with a Trackball MX Ergo from Logitech, disconnecting after ~3 sec. when resuming. Disabling bt_coex_active of iwlwifi solves the issue.
Linux 4.13.5-1-ARCH #1 SMP PREEMPT Fri Oct 6 09:58:47 CEST 2017 x86_64 GNU/Linux
Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)
Comment by bbo2adwuff (bbo2adwuff) - Friday, 10 November 2017, 07:29 GMT

@Inixi: Most likely it'll not be a permanent workaround.
See the upstream bug reports:
https://bugzilla.kernel.org/show_bug.cgi?id=197147
https://bugzilla.kernel.org/show_bug.cgi?id=197807
Comment by Jonathan Kohler (jkohler) - Sunday, 26 November 2017, 04:22 GMT
I've had similar problems for a while with the Intel 8265 bluetooth (currently running kernel 4.13.12-1). It seems Windows has a newer firmware for the bluetooth, which persists across a warm reboot after which bluetooth worked fine. I copied the *.sfi firmware file from the windows driver to intel/ibt-12-16.sfi, and it seemed to permanently resolve the issue.
Comment by bbo2adwuff (bbo2adwuff) - Wednesday, 06 December 2017, 08:47 GMT Comment by Laurent Carlier (lordheavy) - Wednesday, 06 December 2017, 23:08 GMT
Please test with linux-firmware-20171205.5d98692 in [testing]
Comment by Jonathan Kohler (jkohler) - Thursday, 07 December 2017, 00:05 GMT
It doesn't seem the patches had made it to the master branch upstream when linux-firmware-20171205.5d98692 was updated in testing. The commit that has the relevant patches is fdee922a785212be7ccced6809b337290fdac971, which was just merged to the master.
Comment by loqs (loqs) - Thursday, 07 December 2017, 00:36 GMT
The issue was https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?id=e4252cf670f33410a35d1bf604ac5f35dc211c4d
This change reverts 4 recent bluetooth firmware changes, which were corrupt submissions which git failed to apply the binary portions of. Revert them so fixed versions can be applied.
a42f895 linux-firmware: Update firmware patch for Intel Bluetooth 8260
c113d33 linux-firmware: Update firmware file for Intel Bluetooth 8265
041aff8 linux-firmware: Add firmware file for Intel Bluetooth 9260
73d13b5 linux-firmware: Add firmware file for Intel Bluetooth 9560
So the correct commits just added are
db9964e24d3bacf22319292f64230501edec6cb8 Intel Bluetooth 9560
97339b3a1d3bf3e4c40d679896a27a25fa83765f Intel Bluetooth 9260
9a843a1ce31c162d337b9edce0749c4806fbcd36 Intel Bluetooth 8265
fdee922a785212be7ccced6809b337290fdac971 Intel Bluetooth 8260
with the last being the most recent commit as jkohler noted.
Comment by Evangelos Foutras (foutrelis) - Thursday, 07 December 2017, 01:27 GMT
Bumped again: linux-firmware-20171206.fdee922-1 in [testing]
Comment by bbo2adwuff (bbo2adwuff) - Monday, 11 December 2017, 14:39 GMT
Here linux-firmware 20171206.fdee922-1 works! Thanks!

Loading...