Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55789 - [linux] 4.13 won't recognize boot disk of Macbook Pro

Attached to Project: Arch Linux
Opened by Tobias Bachmann (tobac) - Thursday, 28 September 2017, 11:38 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 06 October 2017, 22:30 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Steffens (heftig)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Since 4.13, I'm unable to boot my Macbook Pro. The kernel complains about the root device not being found (see attached screenshot), which is a LUKS encrypted partition (/dev/sda4) normally mapped under /dev/mapper/root. This does not seem to be a LUKS issue, as "sda{,1,2,3,4}" is not listed in /dev using the emergency shell. Based on this, I conclude that the SSD itself is not being recognized.


(You can ignore the ACPI and USB related errors visible in the screenshot; they existed under 4.12 and it booted just fine. The DMAR stuff is new, though.)



Additional info:
* package version: 4.13.3 (core) and 4.13.4 (testing)

DMI: Apple Inc. MacBookPro11,1/Mac-189A3D4F975D5FFC, BIOS MBP111.88Z.0138.B25.1702171721 02/17/2017

# lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.1 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 2 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1c.5 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 6 (rev e4)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Multimedia controller: Broadcom Limited 720p FaceTime HD Camera
03:00.0 Network controller: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter (rev 03)
04:00.0 SATA controller: Marvell Technology Group Ltd. 88SS9183 PCIe SSD Controller (rev 14)
05:00.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
06:00.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
06:03.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
06:04.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
06:05.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
06:06.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
07:00.0 System peripheral: Intel Corporation DSL5520 Thunderbolt 2 NHI [Falcon Ridge 4C 2013]

This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 06 October 2017, 22:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.13.5-1
Comment by Daniel de Oliveira (menelkir) - Thursday, 28 September 2017, 12:23 GMT
Confirmed the same bug with MacBookAir6,1. I've also tested linux-zen 4.13.3-1 with the same issue. It works fine with 4.12.13-1.
Since DMAR seems to be a video issue and the internal pcie ssd doesn't show (at least for me), perhaps it's a pci-e issue?
Comment by Jan Steffens (heftig) - Thursday, 28 September 2017, 12:28 GMT
intel_iommu=off probably helps here.
Comment by Tobias Bachmann (tobac) - Thursday, 28 September 2017, 12:39 GMT
Indeed, adding "intel_iommu=off" fixes my problem. Thanks!
Comment by Daniel de Oliveira (menelkir) - Thursday, 28 September 2017, 13:16 GMT
Didn't fixed for me, I even tried intel_iommu=off and iommu=off
Comment by Aurelieng (aurelieng) - Thursday, 28 September 2017, 16:50 GMT
MacbookAir6.2, `intel_iommu=off` fixed the issue.
Comment by Toshihida Ito (oech3) - Sunday, 01 October 2017, 08:56 GMT
MacBookAir6,1 ,intel_iommu=off fixed for me.
Comment by c (c) - Monday, 02 October 2017, 02:12 GMT Comment by loqs (loqs) - Friday, 06 October 2017, 22:06 GMT
@tobac can you verify with linux 4.13.5-1 currently in testing behaviour should be restored to the same as 4.12
If you want the to boot with intel_iommu=on I suggest you report the issue upstream.
Comment by Tobias Bachmann (tobac) - Friday, 06 October 2017, 22:14 GMT
Yes, I can confirm that 4.13.5-1-ARCH works without intel_iommu=off.

Loading...