Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55777 - Removal of packages breaks other ones

Attached to Project: Arch Linux
Opened by Reynaldo Allan Fulin (AllanDaemon) - Thursday, 28 September 2017, 02:01 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 28 September 2017, 02:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: It seems that after the last change in the gnome-python PKGBUILD as it removes packages used in other programs.

I'm talking about this update that removes some uses packages from repository:
https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/gnome-python&id=a1bbc06ff0ee3ea379a51ed1da040580fff9d6a3


Examples of broken packages (AUR). Check latest comments:

gsieve 0.2-2
https://aur.archlinux.org/packages/gsieve/

system-config-lvm 1.1.18-4
https://aur.archlinux.org/packages/system-config-lvm/


Installing system-config-lvm and running crashes it:
```
$ system-config-lvm
Traceback (most recent call last):
File "/usr/bin/system-config-lvm", line 50, in <module>
import gnome
ImportError: No module named gnome
```

I would like to know if there is any reason to remove those packages, and if there is a replacement for those programs that broke with their removal.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 28 September 2017, 02:16 GMT
Reason for closing:  Not a bug
Additional comments about closing:  they were explicitly, deliberately removed, which answers your first question, and maintainers of broken AUR packages are perfectly welcome to add new AUR packages to fix their stuff, which answers your second question.

Loading...