Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55753 - [keybase] encrypt command is brokenc

Attached to Project: Community Packages
Opened by Denis Kasak (dkasak) - Tuesday, 26 September 2017, 13:16 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 09 March 2018, 05:24 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Eli Schwartz (eschwartz)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
The keybase package seems broken since the `encrypt` command no longer seems to work without KBFS, which isn't included in the package:

% touch foo
% keybase encrypt -i foo -o foo.enc dkasak
▶ ERROR Keybase services aren't running - KBFS client not found. On Linux you need to start them after an update with `run_keybase` command.

Of course, the `run_keybase` command is not included either. Am I missing something?

Additional info:
Name : keybase
Version : 1.0.31-1

Steps to reproduce:
1. Install keybase.
2. Run `keybase encrypt -i <infile> -o <outfile> <recipient>
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 09 March 2018, 05:24 GMT
Reason for closing:  Fixed
Comment by Denis Kasak (dkasak) - Tuesday, 24 October 2017, 07:47 GMT Comment by Eli Schwartz (eschwartz) - Friday, 09 March 2018, 05:24 GMT
I added kbfs to the repos a little while ago as a separate package, so all you need to do is install kbfs.

Loading...