Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55743 - [libvirt] The kvm group ID doesn't match the ID set in /etc/libvirt/qemu.conf

Attached to Project: Community Packages
Opened by Alfredo Matas (amatas) - Monday, 25 September 2017, 09:47 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 25 September 2017, 13:38 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

libvirt has the wrong group GID configured for qemu or the kvm group has incorrect gid:

$ grep \^group /etc/libvirt/qemu.conf
group="78"

On my fresh Arch Linux install group kvm resolves to gid 999:

$ getent group kvm
kvm:x:999:

More info at: https://www.reddit.com/r/archlinux/comments/6wfe2u/fix_for_libvirt_failed_to_initialize_kvm/

Additional info:

Package version:

* libvirt 3.7.0-1
* qemu 2.10.0-1

Config file with the issue:

* /etc/libvirt/qemu.conf


Steps to reproduce:

Set up libvirt with qemu-kvm following the wiki guide: https://wiki.archlinux.org/index.php/libvirt#Using_polkit
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 25 September 2017, 13:38 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#54943  and please search before submitting duplicates.
Comment by Eli Schwartz (eschwartz) - Monday, 25 September 2017, 13:38 GMT
Not really sure why that reddit thread manages to be one of the few places that hasn't noticed the existing discussion.

Loading...