Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55736 - [linux] booting fails on 4.13.3-1

Attached to Project: Arch Linux
Opened by Kerr (zefkerrigan) - Sunday, 24 September 2017, 19:22 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 28 September 2017, 16:19 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I updated to the latest version linux 4.13.3-1 from Testing repository and from the next boot on the computer would not boot anymore. The same issue I had with all versions of linux 4.13.1-1 - 4.13.3-1. Downgrading to the linux 4.12.13-1 kernel from [Core] repository solves the issue.

Additional info:
* package version(linux 4.13.1-1 - 4.13.3-1)
* config and/or log files etc.

cpu: Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz

$ lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 01)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde XT [Radeon HD 7770/8760 / R7 250X]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03)
04:01.0 Network controller: Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01)


This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 28 September 2017, 16:19 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Turns out to be a configuration issue documented in the Wiki.
Comment by loqs (loqs) - Sunday, 24 September 2017, 21:54 GMT
Does adding the boot parameter intel_iommu=off allow the system to boot?
Comment by Kerr (zefkerrigan) - Monday, 25 September 2017, 06:31 GMT
No, rw is the only parameter that I use.
Comment by loqs (loqs) - Monday, 25 September 2017, 10:17 GMT
https://wiki.archlinux.org/index.php/AMDGPU#Enable_Southern_Islands_.28SI.29_and_Sea_Islands_.28CIK.29_support

If that is unsuccessful please supply more information. Is anything displayed on the screen at boot?
If not add the boot parameters loglevel=7 earlyprintk=vga,keep (substitute efi for vga if system boots using efi)
Is anything displayed then?
Comment by Kerr (zefkerrigan) - Thursday, 28 September 2017, 10:39 GMT
When rw is the only parameter that I use, boot stops at this point. I attached the photo as it looks. To restore the normal launch of Arch to me during the photographing each time I had to use archiso to switch to linux-lts, on which I have no problems.
   1.jpg (1.06 MiB)
Comment by Kerr (zefkerrigan) - Thursday, 28 September 2017, 10:45 GMT
When I use the boot parameters
loglevel=7 earlyprintk=vga,keep
boot stops at this point. I attached the photo as it looks.
If this is important information for you, then my motherboard does not have the possibility to use UEFI, so I use grub.
In addition, I tried to upgrade to Linux 4.14.4 from testing, but this did not solve my problem.
   2.jpg (1.86 MiB)
Comment by Kerr (zefkerrigan) - Thursday, 28 September 2017, 11:20 GMT
I did additional experiments, during which I found out that if I switch to the radeon kernel module, then the Arch boot is normal. But, the fact is that I usually use the amdgpu kernel module, and if it is active, while the radeon kernel module is on the black list, then now, after upgrading to Linux 4.13, I get such an impossibility of starting the Arch. On previous versions of the Linux kernel 4.9-4.12 I did not have such a problem.
Here are my usual settings:

/etc/mkinitcpio.conf
MODULES="amdgpu"

and

/etc/modprobe.d/radeon.conf
blacklist radeon

https://wiki.archlinux.org/index.php/AMDGPU#Enable_Southern_Islands_.28SI.29_and_Sea_Islands_.28CIK.29_support
Comment by Kerr (zefkerrigan) - Thursday, 28 September 2017, 11:36 GMT
UPDATE:
I just saw this link updated information, which was not there before. It is likely that it has already been there for some time, but I did not know that it appeared there, and did not notice it. But, also did not know, that the problem can be in it.
Telling a long story briefly, I read what is written there:
https://wiki.archlinux.org/index.php/AMDGPU#Enable_Southern_Islands_.28SI.29_and_Sea_Islands_.28CIK.29_support

"Also, since kernel 4.13, adding the amdgpu.si_support=1 or amdgpu.cik_support=1 kernel parameter is required. Otherwise, AMDGPU will not start and you will end up with either radeon being used instead or the display being frozen during the boot."

I tried it, and it solved my problem. Thank you very much for helping me solve my problem.
I request the closure of this bug.

Loading...