Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55733 - Wine internal crash after updating freetype2

Attached to Project: Arch Linux
Opened by Gabriel Majeri (gabrielm) - Sunday, 24 September 2017, 16:37 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 24 September 2017, 16:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Recently upgraded my system and Wine apps (winecfg, wine control) stopped working, due to "internal wine crash".

I've managed to use WINEDEBUG to pinpoint the cause:
the last function it calls is `font:get_glyph_outline`, and then it has a memory access violation.

I've used `downgrader` to install `freetype2`, version 2.8 (before I had 2.8.1) and the crashing stopped.


Additional info:
* the crash seems to occur only with 64-bit WINEPREFIXs, 32-bit Wine has no problem
* I tried using older versions of wine / wine-staging, nothing changed
* I've attached the `stderr` output of `winecfg`, ran with `WINEDEBUG=+font,seh winecfg`.


Steps to reproduce:
- Install `wine-staging` version 2.17
- Install `freetype2` version 2.8.1
- Start `winecfg` with a 64-bit wine prefix. Observe crashing
- Downgrade to `freetype2`, version 2.8.0
- Crashing stopped
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 24 September 2017, 16:46 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#55667 

Loading...