Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55730 - [lib32-freetype2] The version mismatch with the freetype2 package, there are multiple issues

Attached to Project: Community Packages
Opened by Kerr (zefkerrigan) - Sunday, 24 September 2017, 15:06 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 24 September 2017, 18:41 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Because of the version mismatch with the freetype2 package, there are a lot of issues. Recently the freetype2 package has been updated to version 2.8.1-1. But, since the lib32-freetype2 package still remained outdated version 2.8-2, some applications now can not start at all, or have font rendering problems. At the moment, the lib32-freetype2 package is not even available in the repository "Testing". For example, try running

$ winecfg

This will not work.

Additional info:
* package version(lib32-freetype2 2.8-2)


Steps to reproduce:

To solve this problem, simply update the lib32-freetype2 package.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 24 September 2017, 18:41 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#55667 
Comment by Doug Newgard (Scimmia) - Sunday, 24 September 2017, 15:21 GMT
winecfg problems have nothing to with the mismatch, I doubt your other issues do, either. Give some evidence of the problems.
Comment by Laurent Carlier (lordheavy) - Sunday, 24 September 2017, 17:11 GMT
lib32-freetype2-2.8.1-1 is now in multilib-testing.

Please test so we can close it as duplicated.
Comment by Kerr (zefkerrigan) - Sunday, 24 September 2017, 18:34 GMT
I just updated the package of lib32-freetype2 to 2.8.1-1 from multilib-testing, but unfortunately this did not solve the problem with winecfg, as I thought it would solve it. But, when I do a freetype2 2.8.1-1 package downgrade to freetype2 2.8-2, this definitely solves the problem with running winecfg.
I attached the launch log of winecfg.

Loading...