Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55729 - [wine-staging] winecfg winedbg: Internal crash at 0x7f721094e769

Attached to Project: Community Packages
Opened by none (xxterry1xx) - Sunday, 24 September 2017, 12:57 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 24 September 2017, 14:36 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
winecfg keeps ending in a internal crash ever since I recently updated my arch install. this also happens on the normal wine and wine-staging-nine. I have attached an output file using wine debug options.

Additional info:
wine-staging 2.17



Steps to reproduce:
type winecfg in console and it will result in a internal crash
   file (31.8 KiB)
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 24 September 2017, 14:36 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#55667 
Comment by Brett Cornwall (ainola) - Sunday, 24 September 2017, 13:55 GMT
Same here. However, my current wine prefix is working just fine, I'm just unable to create a new one. Attached is the output of `WINEPREFIX=~/.wine64 winecfg`. I've also tried non-winecfg binaries when creating a new prefix and similar results occur.
Comment by Brett Cornwall (ainola) - Sunday, 24 September 2017, 14:10 GMT
It appears this has to do with the recent freetype2 update. See https://bbs.archlinux.org/viewtopic.php?id=230208

Downgrading to 2.8-1 fixes the issue for now.

Can this be refiled into a bug with freetype2?
Comment by Antonio Rojas (arojas) - Sunday, 24 September 2017, 14:36 GMT
No, the fact that this is triggered by a freetype update doesn't mean that it's a freetype bug

Loading...