Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55724 - [wine] cant run winecfg it fail with page fault

Attached to Project: Community Packages
Opened by Pablo Lezaeta (Jristz) - Sunday, 24 September 2017, 06:36 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 24 September 2017, 06:57 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Latest development version (which is the one used on arch for wine 2.17) is unable to run winecfg if is the first action you do.
Further checks show no aparent erro except the unability of run winecfg, programs with progressbar showing errors in the end of the bar (but aparently intalling correctly) and some programs not working due to not have direct8+ even if direct9 and even direct10 is installed.

Runing winecfg with a wine prefi already existent show just this error:

wine: Unhandled page fault on read access to 0x00000008 at address 0x7fe4e950f3a9 (thread 0032), starting debugger...
winedbg: Internal crash at 0x7f553e4363a9

previous wine 2.16 work flawless, with the same setup and programs without need to install any file.

Additional info:
* wine 2.17

Steps to reproduce:
run winecfg in a clean system

Aditional info:
Using Xfs as filesystem with default options.
I will attach the log when winecfg is summoned if no wineprefix exist
   wine.log (2.8 KiB)
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 24 September 2017, 06:57 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#55667 

Loading...