Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55722 - [kibana] options on kibana.yml can't be used after update

Attached to Project: Community Packages
Opened by bad pixel (badpixel) - Saturday, 23 September 2017, 22:42 GMT
Last edited by Levente Polyak (anthraxx) - Thursday, 05 October 2017, 12:00 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

this options can't be used on kibana.yml after update.

pid.file: /var/run/kibana.pid
logging.dest: /var/log/kibana
logging.silent: false #logging.quiet: false
logging.verbose: true


Additional info:

local/kibana 5.6.1-1
Browser based analytics and search dashboard for Elasticsearch

add kibana.yml on this task.

Steps to reproduce:

install/update kibana. uncomment the option bellow on /etc/kibana/kibana.yml then start kibana through systemd (systemctl start kibana)

this option cant be used after update.

pid.file: /var/run/kibana.pid
logging.dest: /var/log/kibana
logging.silent: false #logging.quiet: false
logging.verbose: true

what happens after restart with that options set:
[reversal@rv03prd ~]$ sudo systemctl status kibana
* kibana.service - Kibana - dashboard for Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/kibana.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Sat 2017-09-23 19:23:51 -03; 1s ago
Process: 9801 ExecStart=/usr/bin/node --max-old-space-size=512 /usr/share/kibana/src/cli --quiet --config=/etc/kibana/kibana.yml (code=exited, status=1/FAILURE)
Main PID: 9801 (code=exited, status=1/FAILURE)

Sep 23 19:23:51 rv03prd node[9801]: xsrf: [Object] },
Sep 23 19:23:51 rv03prd node[9801]: logging:
Sep 23 19:23:51 rv03prd node[9801]: { dest: '/var/log/kibana',
Sep 23 19:23:51 rv03prd node[9801]: silent: false,
Sep 23 19:23:51 rv03prd node[9801]: quiet: true,
Sep 23 19:23:51 rv03prd node[9801]: verbose: true } },
Sep 23 19:23:51 rv03prd node[9801]: annotate: [Function] }
Sep 23 19:23:51 rv03prd systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Sep 23 19:23:51 rv03prd systemd[1]: kibana.service: Unit entered failed state.
Sep 23 19:23:51 rv03prd systemd[1]: kibana.service: Failed with result 'exit-code'.


journalctl -xe show me:

[reversal@rv03prd ~]$ journalctl -xe
Sep 23 19:23:51 rv03prd node[9801]: at /usr/share/kibana/src/server/kbn_server.js:153:20
Sep 23 19:23:51 rv03prd node[9801]: at Generator.next (<anonymous>)
Sep 23 19:23:51 rv03prd node[9801]: at step (/usr/share/kibana/src/server/kbn_server.js:77:191)
Sep 23 19:23:51 rv03prd node[9801]: isJoi: true,
Sep 23 19:23:51 rv03prd node[9801]: name: 'ValidationError',
Sep 23 19:23:51 rv03prd node[9801]: details:
Sep 23 19:23:51 rv03prd node[9801]: [ { message: '"verbose" must be one of [false]',
Sep 23 19:23:51 rv03prd node[9801]: path: 'logging.verbose',
Sep 23 19:23:51 rv03prd node[9801]: type: 'any.allowOnly',
Sep 23 19:23:51 rv03prd node[9801]: context: [Object] } ],
Sep 23 19:23:51 rv03prd node[9801]: _object:
Sep 23 19:23:51 rv03prd node[9801]: { pkg:
Sep 23 19:23:51 rv03prd node[9801]: { version: '5.6.1',
Sep 23 19:23:51 rv03prd node[9801]: branch: '5.6',
Sep 23 19:23:51 rv03prd node[9801]: buildNum: 15533,
Sep 23 19:23:51 rv03prd node[9801]: buildSha: 'd1e7b4cfb06c4d9156fb1e691853b36ff5801d57' },
Sep 23 19:23:51 rv03prd node[9801]: dev: { basePathProxyTarget: 5603 },
Sep 23 19:23:51 rv03prd node[9801]: pid: { file: '/var/run/kibana.pid', exclusive: false },
Sep 23 19:23:51 rv03prd node[9801]: cpu: undefined,
Sep 23 19:23:51 rv03prd node[9801]: cpuacct: undefined,
Sep 23 19:23:51 rv03prd node[9801]: server:
Sep 23 19:23:51 rv03prd node[9801]: { port: 63600,
Sep 23 19:23:51 rv03prd node[9801]: host: '192.168.129.33',
Sep 23 19:23:51 rv03prd node[9801]: name: 'reversalseck',
Sep 23 19:23:51 rv03prd node[9801]: maxPayloadBytes: 1048576,
Sep 23 19:23:51 rv03prd node[9801]: autoListen: true,
Sep 23 19:23:51 rv03prd node[9801]: defaultRoute: '/app/kibana',
Sep 23 19:23:51 rv03prd node[9801]: basePath: '',
Sep 23 19:23:51 rv03prd node[9801]: customResponseHeaders: {},
Sep 23 19:23:51 rv03prd node[9801]: ssl: [Object],
Sep 23 19:23:51 rv03prd node[9801]: cors: false,
Sep 23 19:23:51 rv03prd node[9801]: xsrf: [Object] },
Sep 23 19:23:51 rv03prd node[9801]: logging:
Sep 23 19:23:51 rv03prd node[9801]: { dest: '/var/log/kibana',
Sep 23 19:23:51 rv03prd node[9801]: silent: false,
Sep 23 19:23:51 rv03prd node[9801]: quiet: true,
Sep 23 19:23:51 rv03prd node[9801]: verbose: true } },
Sep 23 19:23:51 rv03prd node[9801]: annotate: [Function] }
Sep 23 19:23:51 rv03prd systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Sep 23 19:23:51 rv03prd systemd[1]: kibana.service: Unit entered failed state.
Sep 23 19:23:51 rv03prd systemd[1]: kibana.service: Failed with result 'exit-code'.
Sep 23 19:23:53 rv03prd sudo[9811]: reversal : TTY=pts/0 ; PWD=/home/reversal ; USER=root ; COMMAND=/usr/bin/systemctl status kibana

if i comment out that options, kibana start normally.

[reversal@rv03prd ~]$ sudo systemctl restart kibana
[reversal@rv03prd ~]$ sudo systemctl status kibana
* kibana.service - Kibana - dashboard for Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/kibana.service; enabled; vendor preset: disabled)
Active: active (running) since Sat 2017-09-23 19:30:22 -03; 4s ago
Main PID: 9840 (node)
CGroup: /system.slice/kibana.service
`-9840 /usr/bin/node --max-old-space-size=512 /usr/share/kibana/src/cli --quiet --config=/etc/kibana/kibana.yml

Sep 23 19:30:22 rv03prd systemd[1]: Started Kibana - dashboard for Elasticsearch.
Sep 23 19:30:24 rv03prd node[9840]: (node:9840) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
Sep 23 19:30:26 rv03prd node[9840]: {"type":"log","@timestamp":"2017-09-23T22:30:26Z","tags":["listening","info"],"pid":9840,"message":"Server running at http://192.168.129.33:636
lines 1-10/10 (END)

This task depends upon

Closed by  Levente Polyak (anthraxx)
Thursday, 05 October 2017, 12:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  5.6.2-2
Comment by bad pixel (badpixel) - Thursday, 05 October 2017, 00:09 GMT
sorry to ask, but any idea when this will be fix? im still cant use this options. thanks in advance
Comment by Levente Polyak (anthraxx) - Thursday, 05 October 2017, 00:37 GMT
You don't seem to set quite properly to false, therefor verbose is not allowed to be true:

Sep 23 19:23:51 rv03prd node[9801]: quiet: true,
Sep 23 19:23:51 rv03prd node[9801]: verbose: true } },

name: 'ValidationError',
details:
{ message: '"verbose" must be one of [false]',
path: 'logging.verbose',
type: 'any.allowOnly',
Comment by Levente Polyak (anthraxx) - Thursday, 05 October 2017, 11:52 GMT
turns out the systemd job enforces quiet when using a cli param (--quite).
I'm moving it to the config and set default to quiet: true.
This way it works whenever someone wants to change it.

Loading...