Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55705 - [linux] intel_mmu from 4.13.3-1 causes my Thinkpad T560 to fail to resume from suspend

Attached to Project: Arch Linux
Opened by Ronan Jouchet (ronjouch) - Friday, 22 September 2017, 15:38 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 11 October 2017, 17:44 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

With intel_mmu=on (default in 4.13), on my Thinkpad T560, suspend works, but pressing on POWER / Enter / whatever key (which under 4.12 resumes the system) doesn't resume; I have to force shutdown with a long press on POWER, and restart.

Turning intel_mmu=off from GRUB works around the issue.

Additional info:
* package version: bug present in testing/linux-{4.13.3-1, 4.13.2-1}
* config and/or log files etc: none, please help me help you, I have no idea what to provide and where to look

Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 11 October 2017, 17:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.13.5-1
Comment by Ronan Jouchet (ronjouch) - Saturday, 23 September 2017, 15:27 GMT Comment by Ronan Jouchet (ronjouch) - Friday, 29 September 2017, 12:18 GMT
News:

- A few users affected on Reddit: https://www.reddit.com/r/archlinux/comments/72z2rv/linux_41331_is_in_core/dnmjaeo/

- Got news from Intel engineers on the iommu mailing list, they will be having a look: https://lists.linuxfoundation.org/pipermail/iommu/2017-September/024383.html

- Rolling back to 4.12.13-1 and manually activating `intel_iommu=on`, resume is similarly broken. Thus, this bug has nothing specific to 4.13; `intel_iommu={on, igfx_on}` probably have been breaking resume for a long time on my system, I just happened to notice it now due to being `on` by default.

Loading...