Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55684 - [intel-gpu-tools] 1.19 intel_gpu_top fails to start under X

Attached to Project: Community Packages
Opened by Tom Jakubowski (tomjakubowski) - Wednesday, 20 September 2017, 06:45 GMT
Last edited by Jelle van der Waa (jelly) - Thursday, 16 November 2017, 18:57 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

intel_gpu_top fails to start when started from a terminal within an X session, complaining that drm_open_driver_master failed. Error log attached. Switching to another virtual console to run intel_gpu_top works, but switching back to the X console then makes X crash. (OMM anyway, haven't seen anyone else report that part of it.)

See https://bbs.archlinux.org/viewtopic.php?pid=1732114 and upstream bug here: https://bugs.freedesktop.org/show_bug.cgi?id=102380

The bug was patched upstream in August but as of now Intel has not yet made a stable release including it. Since this bug totally breaks intel_gpu_top, I think it would be reasonable to incorporate this patch into Arch's 1.19 package.

Additional info:
* version 1.19-1
   log.txt (0.2 KiB)
This task depends upon

Closed by  Jelle van der Waa (jelly)
Thursday, 16 November 2017, 18:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed, by updating to 1.20 :)
Comment by Emil (xexaxo) - Thursday, 09 November 2017, 13:51 GMT
Seems like pkgrel wasn't bumped so 1.19-2 is not available.
Note the newly released 1.20 will also need the fix.
Comment by Jelle van der Waa (jelly) - Friday, 10 November 2017, 22:22 GMT
Fixed in 1.20
Comment by Emil (xexaxo) - Friday, 10 November 2017, 23:36 GMT
I failed at git log ... Indeed 1.20 includes the fix, thanks for the package update jelly.

Loading...