AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#55674 - Disowning a package via SSH triggers Python exception

Attached to Project: AUR web interface
Opened by Yen Chi Hsuan (yan12125) - Monday, 18 September 2017, 19:15 GMT
Last edited by Lukas Fleischer (lfleischer) - Wednesday, 01 November 2017, 08:23 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.4.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Steps to reproduce:

$ ssh aur@aur.archlinux.org disown js52
Traceback (most recent call last):
File "/usr/bin/aurweb-git-serve", line 11, in <module>
load_entry_point('aurweb==4.5.1', 'console_scripts', 'aurweb-git-serve')()
File "/usr/lib/python3.6/site-packages/aurweb-4.5.1-py3.6.egg/aurweb/git/serve.py", line 596, in main
File "/usr/lib/python3.6/site-packages/aurweb-4.5.1-py3.6.egg/aurweb/git/serve.py", line 532, in serve
File "/usr/lib/python3.6/site-packages/aurweb-4.5.1-py3.6.egg/aurweb/git/serve.py", line 238, in pkgbase_disown
File "/usr/lib/python3.6/site-packages/aurweb-4.5.1-py3.6.egg/aurweb/git/serve.py", line 195, in pkgreq_by_pkgbase
File "/usr/lib/python3.6/site-packages/aurweb-4.5.1-py3.6.egg/aurweb/db.py", line 43, in execute
File "/usr/lib/python3.6/site-packages/mysql/connector/cursor.py", line 559, in execute
self._handle_result(self._connection.cmd_query(stmt))
File "/usr/lib/python3.6/site-packages/mysql/connector/connection.py", line 494, in cmd_query
result = self._handle_result(self._send_cmd(ServerCmd.QUERY, query))
File "/usr/lib/python3.6/site-packages/mysql/connector/connection.py", line 396, in _handle_result
raise errors.get_exception(packet)
mysql.connector.errors.ProgrammingError: 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'RequestTypes.Name = 'orphan'' at line 1

I'm the current maintainer of js52.
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Wednesday, 01 November 2017, 08:23 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dupe of  FS#55068 .
Comment by Mark Weiman (markzz) - Monday, 02 October 2017, 22:02 GMT
I can confirm that this occurs, but after investigation on an install of MariaDB on my machine, the statement in question is correct. Also the tests still pass.

This seems like this may be the fault of the AUR server.
Comment by Yen Chi Hsuan (yan12125) - Wednesday, 04 October 2017, 09:58 GMT
Oops, I didn't notice there's a duplicate:  FS#55068 

Loading...