Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55646 - [mesa] mesa-17.2 freezes browser process playing H264 video via VA-API

Attached to Project: Arch Linux
Opened by Eric Wang (enihcam) - Saturday, 16 September 2017, 00:28 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 22 December 2017, 15:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

alim115 commented on 2017-09-15 04:52 (edited on 2017-09-15 06:05 by alim115)
I did a bisect on mesa 17.2 and tracked down the change that broke vaapi. The change is specific to Gen8+ GPUs. It affects Broadwell GPUs for sure and possibly Skylake+ GPUs.

https://cgit.freedesktop.org/mesa/mesa/commit/?h=17.2&id=8ec5a4e4a4a32f4de351c5fc2bf0eb615b6eef1b

@maximbaz If you have time to make your own mesa-17.2 build, can you try reversing the patch (only the third block needs to be backed out: brw_state_upload.c)? No one else commenting that they have the issue.

It fixes the vaapi problem on my laptop and doesn't seem to break anything else.

Additional info:
* package version(s)
17.2

* config and/or log files etc.


Steps to reproduce:
1. install mesa-17.2
2. install chromium-vaapi-bin
3. enable vaapi accelaration
4. open a HTML5 video
5. expected playback smoothly, but actually freeze the whole process
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 22 December 2017, 15:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa 17.3.0-1
Comment by Emil (xexaxo) - Monday, 18 September 2017, 10:23 GMT
You can try the Mesa 17.2.1 (released last night).

If the issue is still there - do open a bug against Mesa see [1].
Informing the developers about this regression.


[1] https://01.org/linuxgraphics/documentation/how-report-bugs
Comment by Alberto (agm28011997) - Tuesday, 19 September 2017, 21:41 GMT
not only for chroomium, vaapi and mesa cause freezes with mpv and smplayer, not tried mplayer vaapi yet and vlc, only in some HD intel models, not all
Comment by Alberto (agm28011997) - Saturday, 30 September 2017, 01:02 GMT
this bug all affect GMA intel cards.. since the update of mesa my pc freezes with mpv with vaapi..very old card but before it used to function well
Comment by Dieter Roever (Dieter9) - Wednesday, 04 October 2017, 12:39 GMT
I got the same problem with mesa since the update to 17.2. My system freeze, when playing mp4/h264 videos.
The problem can be fixed by downgrading the mesa package to mesa-17.2.1-3-x86_64 and leaving all other packages as they are.
Processor is Intel Core i5, Clarkdale i5-660 @ 3.3GHz x 2 (Westmere architektur) and integrated GPU with HD Graphics (Ironlake).
Comment by Emil (xexaxo) - Wednesday, 04 October 2017, 14:41 GMT
I doubt Arch maintainers will be able to sort out the issue. Please report it upstream?
Comment by Eric Wang (enihcam) - Thursday, 23 November 2017, 13:13 GMT
The fix is here:
https://patchwork.freedesktop.org/patch/188597/

Please patch. Thanks!

Loading...