Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55620 - Update of glibc causes kernel panic because no init can be found

Attached to Project: Arch Linux
Opened by Lasse (Lasse100) - Wednesday, 13 September 2017, 13:37 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 14 September 2017, 09:52 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The update of glibc 2.26-1 to 2.26-2 causes a kernel panic during boot, because no working init can be found:
"Not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/init.txt fot guidance."

I know this is caused by glibc because all other packages, except for lib32-glibc and binutils are up to date, and if I upgrade glibc to any version higher than 2.26-1, and then run "mkinitcpio -p linux", I get the kernel panic.

It therefore seems that this kernel panic is caused by a commit on the glibc project somewhere between the release of version 2.26 (https://sourceware.org/git/?p=glibc.git;a=commit;h=1c9a5c270d8b66f30dcfaf1cb2d6cf39d3e18369) and the commit currently used by 2.26-2 (https://sourceware.org/git/?p=glibc.git;a=commit;h=947e2e0a9410c18eb44144456c7fe8e7c0e2a999).
I have been trying to bisect these commits, but I do not really have the necessary skills to do this.

At least one other person has this problem, as can be read in the following forum thread:
https://bbs.archlinux.org/viewtopic.php?pid=1735665#p1735665
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 14 September 2017, 09:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  OP request: fixed by glibc 2.26-4
Comment by Thomas (kugel.) - Wednesday, 13 September 2017, 22:33 GMT
I'm affected too. Can you share the set of working packages or where can I get them?
Comment by Lasse (Lasse100) - Wednesday, 13 September 2017, 22:39 GMT
My system is fully up-to-date, except for the following three packages:
$ pacman -Q binutils glibc lib32-glibc
binutils 2.28.0-4
glibc 2.26-1
lib32-glibc 2.25-7

I do now realize that you could probably also fully upgrade lib32-glibc and binutils, because their dependency of glibc >= 2.26 is satisfied (before, I was using glibc 2.25-7). This is untested though.
Comment by Thomas (kugel.) - Thursday, 14 September 2017, 04:55 GMT
I updated the system via a ubuntu live cd, since I saw glibc was updated to 2.26-4. Indeed, this update fixes the boot for me.

I did a pacman -Syu, and then manually rebuilt the initramfs file (mkinitcpio -p linux)
Comment by Lasse (Lasse100) - Thursday, 14 September 2017, 08:40 GMT
Confirmed. Since this seems to be solved, I suggest closing this issue.

Loading...