Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55580 - [cuda] nvcc fails any compilation

Attached to Project: Community Packages
Opened by Simon (Giggi) - Sunday, 10 September 2017, 18:44 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 13 September 2017, 15:47 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
If I try to compile any program with nvcc I've always the same error:

$ nvcc max.cu -Wno-deprecated-gpu-targets
/usr/include/bits/floatn.h(61): error: invalid argument to attribute "__mode__"

/usr/include/bits/floatn.h(73): error: identifier "__float128" is undefined

2 errors detected in the compilation of "/tmp/tmpxft_00004e70_00000000-9_max.cpp1.ii".


Additional info:
cuda 8.0.61-2


Steps to reproduce:
Try to compile any cuda application ....

nvcc hello.cu

something like this: http://www.computer-graphics.se/hello-world-for-cuda.html

Note:
The problem seems to be appeared after the last gcc update.
But nvcc require gcc 5.


This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 13 September 2017, 15:47 GMT
Reason for closing:  Fixed
Comment by Luís Moreira (knap) - Monday, 11 September 2017, 00:26 GMT
Can confirm the same behavior on my system, GT 520M.
Comment by Simon (Giggi) - Monday, 11 September 2017, 05:29 GMT
It's a problem with the glibc 2.26
https://devtalk.nvidia.com/default/topic/1023776/-request-add-nvcc-compatibility-with-glibc-2-26/?offset=2

The solutions are downgrade the glibc or install the RC of cuda 9

Comment by Simon (Giggi) - Monday, 11 September 2017, 18:46 GMT
I've downgraded to the glibc 2.25 and nvcc is back and working.

[Please note that actually for job I'm developing an application with the nvcc compiler, so for me, cuda, is a critical package].
Comment by Eli Schwartz (eschwartz) - Tuesday, 12 September 2017, 02:28 GMT
At the top of every page on the bugtracker it links to http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

I encourage you to read up on the section titled "Severity".
Your bug is *not* critical, stop spreading FUD.
Comment by Simon (Giggi) - Tuesday, 12 September 2017, 08:29 GMT
Sorry for the FUD
But according severity classification this bug should be "High".
"nvcc" is the main application of cuda.
Comment by Nikolay Bogoychev (Dheart) - Tuesday, 12 September 2017, 15:49 GMT
Shouldn't we then package CUDA-9 RC instead of CUDA-8 since 8 is broken anyways...
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 13 September 2017, 08:19 GMT
I'm not legally allowed to. We have to wait until release. I'll hack something that'll work for now but it's going to be super dirty.
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 13 September 2017, 13:34 GMT
Should be fixed now with current CUDA.
Comment by Simon (Giggi) - Wednesday, 13 September 2017, 15:15 GMT
For CUDA RC-9 we can create a PKGBUILD in AUR.
But the download and usage of the package is allowed only if you are subscribed to the Nvidia developer website.

(At the moment the downgrade of glibc is working without any problem).

Edit: cuda-8.0.61-3-x86_64 is still working
TNX.

Loading...