Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55578 - [mesa] 17.2.0-2 crashes Team Fortress 2 after a few seconds

Attached to Project: Arch Linux
Opened by Marcus Behrendt (mareex) - Sunday, 10 September 2017, 18:09 GMT
Last edited by Laurent Carlier (lordheavy) - Saturday, 23 December 2017, 06:43 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
With version 17.2.0 Team Fortress 2 is not playable any longer. After a few seconds screen will freeze and sound starts looping.
REISUB will only works sporadically but most of the time a hard reset is required.
Issue has already been reported here https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=874656.
Downgrading to 17.1.8-2 helps for the moment.
As this seems to be an upstream bug I want the packager to be aware of it in case he stumbles over a solution. I will be attentive, too.

Additional info:

x86_64 architecture

00:02.0 VGA compatible controller: Intel Corporation Iris Graphics 540 (rev 0a) (prog-if 00 [VGA controller])
Subsystem: Intel Corporation Device 2063
Flags: bus master, fast devsel, latency 0, IRQ 275
Memory at de000000 (64-bit, non-prefetchable) [size=16M]
Memory at 80000000 (64-bit, prefetchable) [size=1G]
I/O ports at f000 [size=64]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915


Steps to reproduce:

Start TF2 and try to play a game.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Saturday, 23 December 2017, 06:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  lib32-mesa 17.3.0-2
Comment by Emil (xexaxo) - Friday, 22 December 2017, 14:10 GMT
Sounds like upstream bug https://bugs.freedesktop.org/show_bug.cgi?id=102435
It should be resolved in Mesa 17.2.7 and Mesa 17.3.0 - Marcus can you confirm?
Comment by Marcus Behrendt (mareex) - Friday, 22 December 2017, 23:50 GMT
I can confirm the bug is resolved in lib32-mesa 17.3.0-2.

Loading...