Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55573 - Kodi crashes at startup when using MySQL-client instead of MariaDB

Attached to Project: Arch Linux
Opened by Francois (francoism90) - Sunday, 10 September 2017, 09:43 GMT
Last edited by Jan de Groot (JGC) - Sunday, 10 September 2017, 11:36 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Note: I'm forced to use MySQL instead of MariaDB for a few other apps I'm using.

When using MySQL - Kodi crashes on startup because it is unable to find the libmysqlclient.so.18 library file.
I've tried symlinking the missing file with libmysqlclient.so but this doesn't work because the library simple doesn't match.

Additional info:
* kodi 17.4-1
* mysql 5.7.19-1


Steps to reproduce:
Installing Kodi with MariaDB works fine, upgrading/using MySQL results in a crash at startup.

Would it be possible to fix this issue?
I'm aware AUR packages are not supported, but I didn't know Kodi was depending on MariaDB because it didn't in the past.

Thanks.
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 10 September 2017, 11:36 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Sunday, 10 September 2017, 11:35 GMT
Kodi depends on libmysqlclient.so.18, MySQL 5.7 provides libmysqlclient.so.20.

MySQL 5.7 doesn't need to conflict with libmariadbclient, check percona-server for that.

We can't make this work for you.

Loading...