Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55563 - [glibc] 2.26 breaks feral interactive linux games

Attached to Project: Arch Linux
Opened by Tom Englund (gulafaran) - Saturday, 09 September 2017, 11:11 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Wednesday, 13 September 2017, 18:24 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
glibc 2.26 breaks feral interactive games like hitman, life is strange, total war: warhammer.

they all just cleanly crashes without any useful output, not even in stace/ltrace, example of strace https://gist.github.com/gulafaran/bdcb24c7ab679d8257a8260fc07a18b7

it however works with the old glibc 2.25 package.


Steps to reproduce:
launch the games after 2.26 upgrade.
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Wednesday, 13 September 2017, 18:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  glibc 2.26-4
Comment by Denis (d2718nis) - Saturday, 09 September 2017, 16:45 GMT
I also have a problem with recently upgraded glibc 2.26, can't run Django server with PostgreSQL engine:

ImportError: /path/to/virtualenv/.venv/lib/python3.6/site-packages/psycopg2/.libs/libresolv-2-c4c53def.5.so: symbol __res_maybe_init, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

and

django.core.exceptions.ImproperlyConfigured: Error loading psycopg2 module: /path/to/virtualenv/.venv/lib/python3.6/site-packages/psycopg2/.libs/libresolv-2-c4c53def.5.so: symbol __res_maybe_init, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

UPDATE:

Works with downgraded glibc-2.25-7
https://archive.archlinux.org/packages/l/lib32-glibc/lib32-glibc-2.25-7-x86_64.pkg.tar.xz
https://archive.archlinux.org/packages/g/glibc/glibc-2.25-7-x86_64.pkg.tar.xz
Comment by Bartłomiej Piotrowski (Barthalion) - Saturday, 09 September 2017, 18:54 GMT
I don't own any of these games – and I don't suspect any bug on our end. Does Feral have a bug tracker for their games?

@Denis, you need to recreate these virtualenvs. It's not a bug, and unrelated to this one.
Comment by Denis (d2718nis) - Saturday, 09 September 2017, 20:44 GMT
>you need to recreate these virtualenvs
@Barthalion I've tried, but it didn't help. I know that problem appeared just after upgrading glibc and gone away when I installed the old version of it. So, I suppose, it's either related to glibc or to psycopg PostgreSQL adapter. Also I didn't update psycopg package that day.

>Denis, try to invoke pip with '--no-binary :all:'. That should fix it.
That helped, thanks a lot.
Comment by Bartłomiej Piotrowski (Barthalion) - Sunday, 10 September 2017, 17:33 GMT
Denis, try to invoke pip with '--no-binary :all:'. That should fix it.
Comment by Alexander W. Ahjolinna (ahjolinna) - Monday, 11 September 2017, 08:02 GMT
I also have this issue with these other Feral games I own/installed; CoH2 and DoW 2/3, but my other steam games do run just fine so this seems to be a Feral only issue...

@gulafaran: all feral game issues should be reported directly to support@feralinteractive.com
also feral has made a "sysreport.sh" script for their games: https://github.com/FeralInteractive/ferallinuxscripts
Comment by Bartłomiej Piotrowski (Barthalion) - Monday, 11 September 2017, 08:42 GMT
Upstream issue: https://github.com/FeralInteractive/ferallinuxscripts/issues/3
And OpenSuse issue where someone from toolchain team explains that their solution was based on undocumented behavior: https://bugzilla.opensuse.org/show_bug.cgi?id=1056606

Nothing to do here from my perspective. Yes, I could revert the commit that changed the behavior, but it's Feral Interactive that should fix their scripts.
Comment by Tom Englund (gulafaran) - Monday, 11 September 2017, 14:39 GMT
yeah nothing to do from my perspective either, their broken code is broken. atleast the cause and reason is found. and the workaround for their brokeness seems to add the /game/lib/x86_64/ path to LD_LIBRARY_PATH= before running it.
Comment by Bartłomiej Piotrowski (Barthalion) - Tuesday, 12 September 2017, 18:13 GMT
Can you test glibc 2.26-4 from here[1]? I'm about to put it in [testing], but I wait for confirmation from anyone owning affected games.

[1] https://paste.xinu.at/m-vqG/
Comment by Bartłomiej Piotrowski (Barthalion) - Tuesday, 12 September 2017, 18:25 GMT
Works for friend of mine (and also with my poor reproducer in C). Pushed to [testing].
Comment by Leonardo Andrés Gallego (sud_crow) - Wednesday, 13 September 2017, 08:29 GMT
FYI: It seems Feral submited a bug report to opensuse about this, and there is some comments from Feral about being a Glibc regression.

Link with comments from Feral and more information at reddit:
https://www.reddit.com/r/linux_gaming/comments/6zpnci/gol_a_bunch_of_feral_interactive_linux_ports_may/
Comment by Alexander W. Ahjolinna (ahjolinna) - Wednesday, 13 September 2017, 11:52 GMT
the glibc 2.26-4 update did work for me, at least with CoH2 and DoW2 & 3

Loading...