Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55559 - [pacman] gettext should be added as a dependency

Attached to Project: Arch Linux
Opened by Steve M (smmalis37) - Friday, 08 September 2017, 18:33 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 08 September 2017, 21:13 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The paccache command calls gettext, and it is not listed as a dependency. This can result in the following error message:
/usr/bin/paccache: line 63: gettext: command not found

pacman version 5.0.2-2

Steps to reproduce:
Run paccache with no arguments without gettext installed.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 08 September 2017, 21:13 GMT
Reason for closing:  Not a bug
Comment by Eli Schwartz (eschwartz) - Friday, 08 September 2017, 21:12 GMT
gettext is part of the base group, and we do not (yet?) have any policy about what to do with implicit depends on the base group. If and when we get such a policy, we will have to fix many, many packages, and we'll no doubt make a todo list to track them.

For now it makes little sense to track one bug here and one bug there, when some packagers try to add all such dependencies and some packagers try to remove all such dependencies.

Loading...