Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55531 - [rosegarden] build fails - subversion missing?

Attached to Project: Community Packages
Opened by Erich Eckner (deepthought) - Wednesday, 06 September 2017, 06:59 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 04 February 2019, 21:36 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ray Rashif (schivmeister)
David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The build in a clean chroot fails (due to missing subversion?):

[ 1%] Generating svn_header, svnheader.h
make[2]: *** No rule to make target 'src/svnversion.h', needed by 'src/CMakeFiles/rosegardenprivate_autogen'. Stop.
make[1]: *** [CMakeFiles/Makefile2:205: src/CMakeFiles/rosegardenprivate_autogen.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
-- Could NOT find Subversion (missing: Subversion_SVN_EXECUTABLE)
-- Build key 02dff44ec7
[ 1%] Built target svnheader

Additional info:
* package version(s)
rosegarden-17.04-2 (git revision 110967367471a062d0b6cfdc860ad471d723b7de)
* config and/or log files etc.
full log is attached

Steps to reproduce:
> staging-x86_64-build
   log (15.5 KiB)
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 04 February 2019, 21:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  upstream update rosegarden 17.12-1 from quite some time ago
Comment by Erich Eckner (deepthought) - Wednesday, 13 September 2017, 13:49 GMT
makedepends+=(subversion)
fixed the mentioned issue, and with also applying
https://anonscm.debian.org/git/pkg-multimedia/rosegarden.git/plain/debian/patches/svnheader.patch?id=1ebdf65
I was finally able to compile it.
The debian bug report is:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=871213

Loading...