Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55469 - [gajim] add new optional dependency on python2-pygments

Attached to Project: Arch Linux
Opened by √Čtienne Deparis (milouse) - Saturday, 02 September 2017, 10:34 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 04 September 2017, 15:06 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Would it be possible to add a new dependency on python2-pygments, which is required by some Gajim plugins or does it sounds too generic? Thanks.

Additional info:
* gajim 0.16.8-2
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 04 September 2017, 15:06 GMT
Reason for closing:  Won't implement
Comment by Doug Newgard (Scimmia) - Saturday, 02 September 2017, 16:08 GMT
Are these plugins that are part of a package or ones you're installing from elsewhere?
Comment by √Čtienne Deparis (milouse) - Sunday, 03 September 2017, 15:50 GMT
Gajim has a plugin manager, which show you a list of available plugin as soon as you open it (they are developed by the same developers as the main application). You can install them by checking their related checkboxes. Theses plugins are not available as separate arch package. They are only available through the gajim plugin manager (what is fine, though). Some of them require external python lib, which are not dependencies of the main package.

The problem is the following. I want to install the plugin A. A need the python pygments lib to works as expected. I have to figure out by myself that on archlinux this lib is available through the python2-pygments package. I install it. Some time later, as I want to cleanup a bit my linux box, I look at the libs I installed, which seems to be needed by nobody. I may uninstall them, as I have no way to remember why this specific lib is here. Hence the proposal to mark them as optional dependency in order to have gajim listed as optional target and help us remember why we install it.
Comment by Doug Newgard (Scimmia) - Sunday, 03 September 2017, 16:53 GMT
This isn't really feasible unless the author has a specific set of libs that they use for plugins. You don't know if you have them all, and they could change at any time independent of the package.
Comment by √Čtienne Deparis (milouse) - Monday, 04 September 2017, 14:58 GMT
Thus I think this ticket can be closed as Won't fix.

Loading...