Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55441 - [obs-studio] Add FTL support

Attached to Project: Community Packages
Opened by Seth VanHeulen (svanheulen) - Wednesday, 30 August 2017, 17:13 GMT
Last edited by Jonathan Steel (jsteel) - Tuesday, 21 September 2021, 21:00 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Jonathan Steel (jsteel)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Support for Mixer.com's FTL protocol was added in version 20.0.x but the "ftl-sdk" needed to compile support for it is included as a git submodule which isn't included in the release archive on github.

Additional info:
* version 20.0.1-2

Steps to reproduce:
Setup streaming to the "Mixer.com - FTL" service. When you attempt to start streaming you will get an error. Checking the log will show "Output ID 'ftl_output' not found".
This task depends upon

Closed by  Jonathan Steel (jsteel)
Tuesday, 21 September 2021, 21:00 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Not enough votes on AUR packages to show enough interest in this feature
Comment by Jonathan Steel (jsteel) - Thursday, 31 August 2017, 13:34 GMT
How about creating an ftl-sdk package in the AUR, then test building obs against that and if it adds the functionality you require, I'll move ftl-sdk to [community] and add it to obs make/optdepends. How does that sound?
Comment by Seth VanHeulen (svanheulen) - Thursday, 31 August 2017, 14:17 GMT
It looks like this will require some patches since it expects the ftl-sdk to be in the source tree: https://github.com/jp9000/obs-studio/blob/master/plugins/obs-outputs/CMakeLists.txt#L22-L72
And the ftl-sdk does something similar with it's jansson dependency :(
I don't know a lot about cmake but I'll see if I can figure something out and get some upstream pull requests accepted to make things easier.
Comment by Jonathan Steel (jsteel) - Thursday, 31 August 2017, 14:33 GMT
OK, so I wonder why they don't include a copy in their release tarball; how do they expect us to build it with FTL support. If you can get clarification from upstream that would be great, thanks.
Comment by Jonathan Steel (jsteel) - Wednesday, 22 November 2017, 09:08 GMT
Have you been able to find more information about this?
Comment by Sefa Eyeoglu (Scrumplex) - Tuesday, 04 May 2021, 07:34 GMT
  • Field changed: Percent Complete (100% → 0%)
I am currently trying to get the changes into the upstreams.

ftl_sdk still uses an in-tree build of libjansson (which is actually already packaged in community).

I created an issue there to resolve that first: https://github.com/mixer/ftl-sdk/issues/92
Now to be honest I don't expect much, as the company behind it (Mixer, by Microsoft) is basically gone.

I might be able to create a patch around it, but it seems bad in the first place as the project is basically dead.


About OBS:
We should first resolve ftl_sdk before moving onto OBS. As mentioned a fork might be necessary for any activity there.

Comment by Trystan Mata (tytan652) - Tuesday, 11 May 2021, 09:10 GMT
FTL in OBS Studio is in deprecation
https://github.com/obsproject/obs-studio/discussions/4021

Edit: I don't say that adding it is a wrong idea.
Comment by Sefa Eyeoglu (Scrumplex) - Tuesday, 11 May 2021, 09:32 GMT
Well it is deprecated, but it is still supported for a relatively long time.

FTL is packaged here https://aur.archlinux.org/packages/ftl-sdk/

I also provide https://aur.archlinux.org/packages/obs-studio-ftl/ which backports PR https://github.com/obsproject/obs-studio/pull/4018

So with the next OBS release, it will be possible to have it supported here.
Comment by Jonathan Steel (jsteel) - Tuesday, 21 September 2021, 20:58 GMT
While I think we could move ftl-sdk to [community] and add support for this now, the lack of votes here and on the 2 AUR packages makes me think it might be best to leave the packages in place, at least for now.

Loading...