Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55358 - [devtools] mercurial and git need to be installed on the host

Attached to Project: Arch Linux
Opened by Erich Eckner (deepthought) - Wednesday, 30 August 2017, 10:19 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 30 August 2017, 14:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Low
Priority Normal
Reported Version 5.0.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

mercurial or git need to be installed on the host before running staging-x86_64-build and alike to successfully download sources like
"hg+http://bitbucket.org/sinbad/ogre#tag=v${pkgver//./-}" (in community/ogre).

* config and/or log files etc.
log of building ogre is attached.

Steps to reproduce:
Try to build community/ogre via staging-x86_64-build on a system without mercurial installed.
   log (1.4 KiB)
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 30 August 2017, 14:27 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#39097 
Comment by Bartłomiej Piotrowski (Barthalion) - Wednesday, 30 August 2017, 10:36 GMT
My guess is that devtools should depend on svn, hg, git and bzr, or sources shouldn't be downloaded outside chroot.
Comment by Pierre Schmitz (Pierre) - Wednesday, 30 August 2017, 10:38 GMT
If your PKGBUILD uses git it should have a makedepends on git.
Comment by Erich Eckner (deepthought) - Wednesday, 30 August 2017, 10:39 GMT
look at community/ogre - it has mercurial in makedepends, but still fails.
Comment by Pierre Schmitz (Pierre) - Wednesday, 30 August 2017, 10:43 GMT
Well, looks like makepkg tries to download the sources before installing the makedepends. I am not sure if that is intended. I'd say:
* make makepkg install its deps before downloading the sources
* have devtools depend on every supported vcs
* introduce something like srcdepends :-)
Comment by Erich Eckner (deepthought) - Wednesday, 30 August 2017, 10:46 GMT
I think, the 2nd solution is the best:
It's the least invasive one and brings the fewest changes to running systems, since everyone seems to have all vcs installed anyway (at least it took quite long for this issue to pop up).
But the other solutions sound reasonable, too :-)

Loading...