Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55331 - [openjade] Breaks build of docbook-utils if built "by hand"

Attached to Project: Arch Linux
Opened by Erich Eckner (deepthought) - Tuesday, 29 August 2017, 12:14 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 04 September 2017, 09:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

If the openjade package is built by hand (via staging-x86_64-build) and installed via 'pacman -U', the build of docbook-utils fails with a segfault while executing openjade:

SGML_CATALOG_FILES=/etc/sgml/catalog \
SGML_SEARCH_PATH=../..:../../doc:.. \
jade -t sgml -i html -d ../../docbook-utils.dsl\#html \
-V '%use-id-as-filename%' ../../doc/docbook-utils.sgml
make[2]: *** [Makefile:300: api.html] Segmentation fault (core dumped)


However, if the official openjade package is installed, the compilation of docbook-utils does not fail.

Additional info:
* package version(s)
openjade-1.3.2-4 (git revision 0b8f4487ca0230ddf08a77a6bebfc8e43a98591f)
docbook-utils-0.6.14-8 (same git revision)
* config and/or log files etc.
logs are attached

Steps to reproduce:
> git clone 'git://git.archlinux.org/svntogit/packages.git'
> cd packages
> git checkout 0b8f4487ca0230ddf08a77a6bebfc8e43a98591f
> cd openjade/repos/extra-x86_64
> staging-x86_64-build
> pacman -U openjade-1.3.2-4-x86_64.pkg.tar.xz
> cd ../../../docbook-utils/repos/extra-any
> makepkg -fcrs --asdeps --noconfirm

(note, that docbook-utils is not built with staging-x86_64-build, because we want to use our own openjade package).
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 04 September 2017, 09:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.3.2-5
Comment by Andreas Radke (AndyRTR) - Friday, 01 September 2017, 19:43 GMT
I could built openjade in a clean chroot with testing toolchain without any trouble - so works for me.

No idea what's different in your local system.
Comment by Erich Eckner (deepthought) - Saturday, 02 September 2017, 06:14 GMT
yes, openjade seems to build fine, but when you install the compiled package and then try to compile docbook-utils, there is a segfault in openjade. This segfault does not happen if you install the openjade package from the repositories.
Comment by Michael (MST) - Saturday, 02 September 2017, 23:28 GMT
Seems similar to this: https://bugzilla.redhat.com/show_bug.cgi?id=1306162

Compiling openjade with -fno-lifetime-dse solved it for me.
Comment by Erich Eckner (deepthought) - Sunday, 03 September 2017, 13:41 GMT
I can confirm, that the attached patch fixes the issue for me on both x86_64 and i686 :-)

Loading...