Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55316 - graphicsmagick 1.3.26-3 PKGBUILD tries to remove non-existant directory

Attached to Project: Arch Linux
Opened by David McInnis (daavve) - Sunday, 27 August 2017, 19:23 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 27 August 2017, 21:21 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When running makepkge I get the error:

rm: cannot remove '/home/dave/build/graphicsmagick/pkg/graphicsmagick/usr/lib/perl5/*/core_perl': No such file or directory

The following patch fixes this:

------------------------------------------------------------------------------------------------------------------------
--- PKGBUILD.old 2017-08-27 12:02:03.737110151 -0700
+++ PKGBUILD 2017-08-27 12:06:14.495751675 -0700
@@ -56,6 +56,6 @@
make install

# Remove perllocal.pod and .packlist
- rm -r "${pkgdir}"/usr/lib/perl5/*/core_perl
- rm "${pkgdir}"/usr/lib/perl5/*/vendor_perl/auto/Graphics/Magick/.packlist
+ rm -r "${pkgdir}"/usr/lib/perl5/core_perl
+ rm "${pkgdir}"/usr/lib/perl5/vendor_perl/auto/Graphics/Magick/.packlist
}




------------------------------------------------------------------------------------------------------------------------
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 27 August 2017, 21:21 GMT
Reason for closing:  Not a bug
Additional comments about closing:  user request: I just installed the newest perl package and realized there is nothing wrong this the currentl PKGBUILD.

Loading...