Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55244 - [mesa] 17.1.7 causes display corruption in Plasma/SDDM

Attached to Project: Arch Linux
Opened by Antonio Rojas (arojas) - Tuesday, 22 August 2017, 22:29 GMT
Last edited by Laurent Carlier (lordheavy) - Wednesday, 20 September 2017, 14:07 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Mesa 17.1.7 causes multiple display glitches in Plasma and SDDM: panel and tooltip transparency is lost, avatars are not displayed on the lock screen and on sddm, password bullets are also not displayed. Downgrading to 17.1.6 fixes the issue.
Will try to bisect it tomorrow, reporting it for now to prevent it moving to extra

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
Subsystem: Sony Corporation Device 90c3
Flags: bus master, fast devsel, latency 0, IRQ 44
Memory at b2000000 (64-bit, non-prefetchable) [size=4M]
Memory at a0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 5000 [size=64]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

This task depends upon

Closed by  Laurent Carlier (lordheavy)
Wednesday, 20 September 2017, 14:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa 17.1.8-2
Comment by patrick (potomac) - Tuesday, 22 August 2017, 23:04 GMT
this problem occurs with all type of graphic card ?
or only on intel graphic card ?
Comment by patrick (potomac) - Tuesday, 22 August 2017, 23:08 GMT
well I have the answer here :

 FS#55243 
Comment by Antonio Rojas (arojas) - Tuesday, 22 August 2017, 23:15 GMT
Rebuilding 17.1.7 against [extra] fixes the problem. So this seems to be an issue with the new toolchain in [testing]
Comment by rainer (raneon) - Wednesday, 23 August 2017, 10:18 GMT
I have the same issues on Intel (mesa 17.1.7 from testing) and even on my AMD GPU with mesa-git. In my case Youtube videos in Firefox (OpenGL rendering) and the start screen of the Big Picture mode of Steam show a purple overlay as well.
Comment by Laurent Carlier (lordheavy) - Friday, 25 August 2017, 09:04 GMT
Please test with mesa-17.1.7-2, i workaround the bug using toolchain from extra
Comment by rainer (raneon) - Friday, 25 August 2017, 09:28 GMT
With mesa-17.1.7-2 the issues are fixed on my Intel GPU. Thanks!
Comment by Steffen Klee (kleest) - Friday, 25 August 2017, 12:08 GMT
Can confirm the issues are fixed with mesa-17.1.7-2 when using an AMD GPU with radeonsi.
Comment by Antonio Rojas (arojas) - Monday, 28 August 2017, 12:01 GMT
This is yet another fallout from the xlocale.h removal. The attached patch fixes the problem (not upstreamable, it needs to properly account for the glibc version number)
Comment by Laurent Carlier (lordheavy) - Monday, 28 August 2017, 13:40 GMT Comment by Andreas Radke (AndyRTR) - Monday, 04 September 2017, 11:37 GMT

Loading...