Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55243 - [mesa] 17.1.7 update breaks webcam capture display :(

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Tuesday, 22 August 2017, 19:17 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 24 August 2017, 16:52 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: I noticed after upgrading to Mesa 17.1.7, I got a pink overlay on my webcam capture.

Reverting to mesa 17.1.6 fixes this display bug. I'm using nouveau driver if it is important to add.

Additional info:
mesa : 17.1.7-1
xf86-video-nouveau : 1.0.15-2

Steps to reproduce:
1. Get a computer with archlinux testing and a nvidia card.
2. Get Mesa 17.1.7 update
3. Launch any webcam display software like guvcview or cheese
4. Display is broken with a pink overlay :(

See attached screen. Reverting to mesa 17.1.6 fixes the bug. Maybe a rebuild of xf86-video-nouveau is needed?
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 24 August 2017, 16:52 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#55244 
Comment by Frederic Bezies (fredbezies) - Wednesday, 23 August 2017, 10:23 GMT
Looks like it is a bug in xf86-video-nouveau driver :(

I installed nvidia340xx driver for my old nvidia card (a GeForce G210), and no more pink overlay in webcam capture software with mesa 17.1.7... Ouch!

Bug reported upstream : https://bugs.freedesktop.org/show_bug.cgi?id=102368
Comment by Andreas Radke (AndyRTR) - Wednesday, 23 August 2017, 13:41 GMT
Please check with rebuilding against core/extra repos if it's working for you with our old toolchain. This could be a duplicate of  FS#55244 .
Comment by Frederic Bezies (fredbezies) - Thursday, 24 August 2017, 16:37 GMT
@Andreas : you nailed it :(

Closing this bug as duplicate of #55244.

Loading...