Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55235 - [plasma-wayland-session] Arrow keys do not work in Qemu and Plasma Wayland

Attached to Project: Arch Linux
Opened by Tuxle (dns2utf8) - Tuesday, 22 August 2017, 06:15 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 12 September 2017, 06:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Using Qemu works in general, but the arrow and page keys do not work.
The same command works with Gnome3 wayland and Plasma X11.

I started Qemu like this:
qemu-system-x86_64 -k de-ch -cpu host -enable-kvm -smp 2 -m 4096 -usb -usbdevice tablet -hda ~/kvm/arch_wayland.qcow2 -name "Arch_Wayland" -vga qxl

Additional info:
* qemu 2.9.0-3
* plasma-wayland-session 5.10.4-2
* gnome-session 3.24.1-1


Steps to reproduce:
1. Install Plasma with wayland-session
2. Run Qemu and press the arrow keys in the bootloader or any other state -> nothing happens
3. PageUp will insert a Slash
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 12 September 2017, 06:26 GMT
Reason for closing:  Works for me
Comment by Tuxle (dns2utf8) - Tuesday, 22 August 2017, 06:19 GMT Comment by Antonio Rojas (arojas) - Friday, 08 September 2017, 21:57 GMT
works fine here with a simple Arch ISO image.

Loading...