Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55228 - [phpvirtualbox] SOAP Validation constraint violation

Attached to Project: Community Packages
Opened by Thomas (Tom077) - Monday, 21 August 2017, 19:09 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 10 January 2018, 19:57 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

VM config can't be edited.
New VM can't be created.

Error windows appears (see attached screenshots).

It seems to be an issue with SOAP dialogues between phpvirtualbox and the new 5.1.26 vboxwebserver service (wrong arguments content given to __soapCall).

I attached a patch proposal that fix the issue.

Additional info:

phpvirtualbox 5.0_5-2
apache 2.4.27-1
php 7.1.8-1

config.php is attached.


Steps to reproduce:
Add a new VM
or
Edit a VM config and then validate.

This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 10 January 2018, 19:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  phpvirtualbox 5.2_0rc1-4
Comment by Tudor Holton @ Smart Guide (sg) - Friday, 10 November 2017, 05:38 GMT
Hi Thomas,

Thank you for the patch. We have applied it upstream and can be see in this commit: https://github.com/phpvirtualbox/phpvirtualbox/commit/4c639d47106d0e5a272ef4a75eeaf7cb3a4a9d05

It will be merged into master once we have completed the RC process. Please verify it works for you.

Cheers,
Tudor
Comment by Thomas (Tom077) - Saturday, 11 November 2017, 14:37 GMT
Hi Tudor,

I found 3 more buggy "SOAP" functions that are called when editing storage controllers of an existing VM.

Here is a patch to fix theses 3 functions.

Thomas

Comment by Sergej Pupykin (sergej) - Monday, 08 January 2018, 14:01 GMT
I guess it should be fixed in 5.2_0rc1-2
Comment by Thomas (Tom077) - Wednesday, 10 January 2018, 14:42 GMT
  • Field changed: Percent Complete (100% → 0%)
Upstream has not fixed that in 5.2rc1-2
Comment by Eli Schwartz (eschwartz) - Wednesday, 10 January 2018, 14:45 GMT
What exactly about removing endpoints/lib/*.wsdl in prepare() is supposed to fix this? The file endpoints/lib/vboxconnector.php is still broken...

We should backport the patch* mentioned above, and also this I guess: https://github.com/phpvirtualbox/phpvirtualbox/commit/c84bf6b462cc43854fa7e04ce0fa71cadd4eadc7


EDIT:
* - ==> commit ;)
Comment by Sergej Pupykin (sergej) - Wednesday, 10 January 2018, 14:51 GMT
Ah, sorry. 5.2_0rc1-4 should fix this.
Comment by Thomas (Tom077) - Wednesday, 10 January 2018, 14:59 GMT
The patch mentioned above (0002-bug-fix.patch) was a first try to fix the problem. You'd better use the github commit because it fixes another SOAP function.
Comment by Sergej Pupykin (sergej) - Wednesday, 10 January 2018, 15:03 GMT Comment by Thomas (Tom077) - Wednesday, 10 January 2018, 19:15 GMT
I have just installed phpvirtualbox 5.2_0rc1-4 with apache 2.4.29-1, php 7.2.1-1 and virtualbox 5.2.4-1.

I have tested basic functionalities and I don't get any more "SOAPFault" errors.

Thanks a lot!

Loading...